{"answers":{"affected":"12 open source packages ship an affected version, including @fedify/fedify.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54888 exists.","fix":"Upgrade @fedify/fedify to a fixed version for your release line: 1.3.20, 1.4.13, 1.5.5 or 1.6.8.","what":"CVE-2025-54888 is a high-severity authentication bypass vulnerability in fedify-dev fedify, published on 9 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-54888 and fix it if it is affected.\n\nWhat it is: CVE-2025-54888 is a high-severity authentication bypass vulnerability in fedify-dev fedify, published on 9 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54888 exists.\n\nAffected packages and fixed versions:\n- @fedify/fedify (npm): affected all versions; fixed in 1.3.20\n- @fedify/fedify (npm): affected all versions; fixed in 1.3.20\n- @fedify/fedify (npm): affected from 1.4.0-dev.585; fixed in 1.4.13\n- @fedify/fedify (npm): affected from 1.4.0-dev.585; fixed in 1.4.13\n- @fedify/fedify (npm): affected from 1.5.0-dev.636; fixed in 1.5.5\n- @fedify/fedify (npm): affected from 1.5.0-dev.636; fixed in 1.5.5\n- @fedify/fedify (npm): affected from 1.6.0-dev.754; fixed in 1.6.8\n- @fedify/fedify (npm): affected from 1.6.0-dev.754; fixed in 1.6.8\n- @fedify/fedify (npm): affected from 1.7.0-pr.251.885; fixed in 1.7.9\n- @fedify/fedify (npm): affected from 1.7.0-pr.251.885; fixed in 1.7.9\n- @fedify/fedify (npm): affected from 1.8.0-dev.909; fixed in 1.8.5\n- @fedify/fedify (npm): affected from 1.8.0-dev.909; fixed in 1.8.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-54888/ (Markdown: https://insights.sbomify.com/CVE-2025-54888/index.md)","id":"CVE-2025-54888","markdown":"https://insights.sbomify.com/CVE-2025-54888/index.md","name":"CVE-2025-54888","record":{"aliases":["GHSA-6jcc-xgcr-q3h4"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"ActivityPub TypeScript library","requires_auth":"none","summary":"Unauthenticated attackers can impersonate any ActivityPub actor by sending forged activities, leading to account takeover and data modification in Fedify-based applications.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"},{"id":"CWE-287","name":"Improper Authentication"}],"description":"Fedify is a TypeScript library for building federated server apps powered by ActivityPub. In versions below 1.3.20, 1.4.0-dev.585 through 1.4.12, 1.5.0-dev.636 through 1.5.4, 1.6.0-dev.754 through 1.6.7, 1.7.0-pr.251.885 through 1.7.8 and 1.8.0-dev.909 through 1.8.4, an authentication bypass vulnerability allows any unauthenticated attacker to impersonate any ActivityPub actor by sending forged activities signed with their own keys. Activities are processed before verifying the signing key belongs to the claimed actor, enabling complete actor impersonation across all Fedify instances. This is fixed in versions 1.3.20, 1.4.13, 1.5.5, 1.6.8, 1.7.9 and 1.8.5.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"@fedify/fedify: Improper Authentication and Incorrect Authorization","id":"CVE-2025-54888","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":12,"n_references":2,"next":{"headline":"A user with elevated privileges can inject XSS in the SNMP traps manufacturer configuration page","id":"CVE-2025-54889"},"packages":[{"ecosystem":"npm","fixed":["1.3.20"],"introduced":["0"],"last_affected":[],"package":"@fedify/fedify","purl":null,"source":"GHSA-6jcc-xgcr-q3h4"},{"ecosystem":"npm","fixed":["1.3.20"],"introduced":["0"],"last_affected":[],"package":"@fedify/fedify","purl":"pkg:npm/%40fedify/fedify","source":"GHSA-6jcc-xgcr-q3h4"},{"ecosystem":"npm","fixed":["1.4.13"],"introduced":["1.4.0-dev.585"],"last_affected":[],"package":"@fedify/fedify","purl":null,"source":"GHSA-6jcc-xgcr-q3h4"},{"ecosystem":"npm","fixed":["1.4.13"],"introduced":["1.4.0-dev.585"],"last_affected":[],"package":"@fedify/fedify","purl":"pkg:npm/%40fedify/fedify","source":"GHSA-6jcc-xgcr-q3h4"},{"ecosystem":"npm","fixed":["1.5.5"],"introduced":["1.5.0-dev.636"],"last_affected":[],"package":"@fedify/fedify","purl":null,"source":"GHSA-6jcc-xgcr-q3h4"},{"ecosystem":"npm","fixed":["1.5.5"],"introduced":["1.5.0-dev.636"],"last_affected":[],"package":"@fedify/fedify","purl":"pkg:npm/%40fedify/fedify","source":"GHSA-6jcc-xgcr-q3h4"},{"ecosystem":"npm","fixed":["1.6.8"],"introduced":["1.6.0-dev.754"],"last_affected":[],"package":"@fedify/fedify","purl":null,"source":"GHSA-6jcc-xgcr-q3h4"},{"ecosystem":"npm","fixed":["1.6.8"],"introduced":["1.6.0-dev.754"],"last_affected":[],"package":"@fedify/fedify","purl":"pkg:npm/%40fedify/fedify","source":"GHSA-6jcc-xgcr-q3h4"},{"ecosystem":"npm","fixed":["1.7.9"],"introduced":["1.7.0-pr.251.885"],"last_affected":[],"package":"@fedify/fedify","purl":null,"source":"GHSA-6jcc-xgcr-q3h4"},{"ecosystem":"npm","fixed":["1.7.9"],"introduced":["1.7.0-pr.251.885"],"last_affected":[],"package":"@fedify/fedify","purl":"pkg:npm/%40fedify/fedify","source":"GHSA-6jcc-xgcr-q3h4"},{"ecosystem":"npm","fixed":["1.8.5"],"introduced":["1.8.0-dev.909"],"last_affected":[],"package":"@fedify/fedify","purl":null,"source":"GHSA-6jcc-xgcr-q3h4"},{"ecosystem":"npm","fixed":["1.8.5"],"introduced":["1.8.0-dev.909"],"last_affected":[],"package":"@fedify/fedify","purl":"pkg:npm/%40fedify/fedify","source":"GHSA-6jcc-xgcr-q3h4"}],"prev":{"headline":"jwe: Missing AES-GCM authentication tag validation in encrypted JWEs","id":"CVE-2025-54887"},"products":["fedify"],"published":"2025-08-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-04","vendors":["fedify-dev"]},"summary":"Unauthenticated attackers can impersonate any ActivityPub actor by sending forged activities, leading to account takeover and data modification in Fedify-based applications.","url":"https://insights.sbomify.com/CVE-2025-54888/"}