# CVE-2025-54888: @fedify/fedify: Improper Authentication and Incorrect Authorization

> Unauthenticated attackers can impersonate any ActivityPub actor by sending forged activities, leading to account takeover and data modification in Fedify-based applications.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Aug 2025
- **Updated:** 4 Feb 2026
- **Also known as:** GHSA-6jcc-xgcr-q3h4

## What is CVE-2025-54888?

CVE-2025-54888 is a high-severity authentication bypass vulnerability in fedify-dev fedify, published on 9 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fedify is a TypeScript library for building federated server apps powered by ActivityPub. In versions below 1.3.20, 1.4.0-dev.585 through 1.4.12, 1.5.0-dev.636 through 1.5.4, 1.6.0-dev.754 through 1.6.7, 1.7.0-pr.251.885 through 1.7.8 and 1.8.0-dev.909 through 1.8.4, an authentication bypass vulnerability allows any unauthenticated attacker to impersonate any ActivityPub actor by sending forged activities signed with their own keys. Activities are processed before verifying the signing key belongs to the claimed actor, enabling complete actor impersonation across all Fedify instances. This is fixed in versions 1.3.20, 1.4.13, 1.5.5, 1.6.8, 1.7.9 and 1.8.5.

Weakness: CWE-863 (Incorrect Authorization), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2025-54888?

12 open source packages ship an affected version, including @fedify/fedify.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@fedify/fedify` | npm | All versions | 1.3.20 |
| `@fedify/fedify` | npm | All versions | 1.3.20 |
| `@fedify/fedify` | npm | From 1.4.0-dev.585 | 1.4.13 |
| `@fedify/fedify` | npm | From 1.4.0-dev.585 | 1.4.13 |
| `@fedify/fedify` | npm | From 1.5.0-dev.636 | 1.5.5 |
| `@fedify/fedify` | npm | From 1.5.0-dev.636 | 1.5.5 |
| `@fedify/fedify` | npm | From 1.6.0-dev.754 | 1.6.8 |
| `@fedify/fedify` | npm | From 1.6.0-dev.754 | 1.6.8 |
| `@fedify/fedify` | npm | From 1.7.0-pr.251.885 | 1.7.9 |
| `@fedify/fedify` | npm | From 1.7.0-pr.251.885 | 1.7.9 |
| `@fedify/fedify` | npm | From 1.8.0-dev.909 | 1.8.5 |
| `@fedify/fedify` | npm | From 1.8.0-dev.909 | 1.8.5 |

## How do I fix CVE-2025-54888?

Upgrade @fedify/fedify to a fixed version for your release line: 1.3.20, 1.4.13, 1.5.5 or 1.6.8.

## Is CVE-2025-54888 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54888 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54888 and fix it if it is affected.

What it is: CVE-2025-54888 is a high-severity authentication bypass vulnerability in fedify-dev fedify, published on 9 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54888 exists.

Affected packages and fixed versions:
- @fedify/fedify (npm): affected all versions; fixed in 1.3.20
- @fedify/fedify (npm): affected all versions; fixed in 1.3.20
- @fedify/fedify (npm): affected from 1.4.0-dev.585; fixed in 1.4.13
- @fedify/fedify (npm): affected from 1.4.0-dev.585; fixed in 1.4.13
- @fedify/fedify (npm): affected from 1.5.0-dev.636; fixed in 1.5.5
- @fedify/fedify (npm): affected from 1.5.0-dev.636; fixed in 1.5.5
- @fedify/fedify (npm): affected from 1.6.0-dev.754; fixed in 1.6.8
- @fedify/fedify (npm): affected from 1.6.0-dev.754; fixed in 1.6.8
- @fedify/fedify (npm): affected from 1.7.0-pr.251.885; fixed in 1.7.9
- @fedify/fedify (npm): affected from 1.7.0-pr.251.885; fixed in 1.7.9
- @fedify/fedify (npm): affected from 1.8.0-dev.909; fixed in 1.8.5
- @fedify/fedify (npm): affected from 1.8.0-dev.909; fixed in 1.8.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54888/ (Markdown: https://insights.sbomify.com/CVE-2025-54888/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54888
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54888
- OSV: https://osv.dev/vulnerability/CVE-2025-54888

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54888/
Summaries are generated and may contain mistakes; the official description above is the record.
