# CVE-2025-54956: Information disclosure in gh

> The R gh library leaks Authorization headers in HTTP responses, allowing attackers to potentially access sensitive credentials.

- **Severity:** Low 3.2 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Aug 2025
- **Updated:** 25 Nov 2025
- **Also known as:** DEBIAN-CVE-2025-54956, DLA-4378-1, GHSA-gfw5-r5r2-fv73, RSEC-2025-0, UBUNTU-CVE-2025-54956

## What is CVE-2025-54956?

CVE-2025-54956 is a low-severity vulnerability in r-lib gh, published on 3 Aug 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The gh package before 1.5.0 for R delivers an HTTP response in a data structure that includes the Authorization header from the corresponding HTTP request.

Weakness: CWE-669 (Incorrect Resource Transfer Between Spheres)

## Which versions are affected by CVE-2025-54956?

1 open source package ship an affected version, including gh.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gh` | CRAN | From 1.1.0 | 1.5.0 |

## How do I fix CVE-2025-54956?

Upgrade gh to 1.5.0 or later.

## Is CVE-2025-54956 being exploited?

There is no known exploitation of CVE-2025-54956 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54956 and fix it if it is affected.

What it is: CVE-2025-54956 is a low-severity vulnerability in r-lib gh, published on 3 Aug 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-54956 in the wild and no public exploit code.

Affected packages and fixed versions:
- gh (CRAN): affected from 1.1.0; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54956/ (Markdown: https://insights.sbomify.com/CVE-2025-54956/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54956
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54956
- OSV: https://osv.dev/vulnerability/CVE-2025-54956

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54956/
Summaries are generated and may contain mistakes; the official description above is the record.
