CVE-2025-5498 slackero phpwcms Custom Source Tab cnt21.readform.inc.php is_file deserialization
Remote attackers can achieve code execution via unsafe deserialization in the Custom Source Tab, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2025-5498?
CVE-2025-5498 is a medium-severity unsafe deserialization vulnerability in slackero phpwcms, published on 3 Jun 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
A vulnerability was found in slackero phpwcms up to 1.9.45/1.10.8. It has been rated as critical. This issue affects the function file_get_contents/is_file of the file include/inc_lib/content/cnt21.readform.inc.php of the component Custom Source Tab. The manipulation of the argument cpage_custom leads to deserialization. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.9.46 and 1.10.9 is able to address this issue. It is recommended to upgrade the affected component.
Which versions are affected by CVE-2025-5498?
It affects 1 product.
Products include Phpwcms Phpwcms.
How do I fix CVE-2025-5498?
No fix has been published for CVE-2025-5498 yet. Limit exposure of the affected software until one is available.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2025-5498 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5498 exists.
Other vulnerabilities in slackero phpwcms
Sources
Also known as GHSA-5fmq-4fvm-96qg.