{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5498 exists.","fix":"No fix has been published for CVE-2025-5498 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-5498 is a medium-severity unsafe deserialization vulnerability in slackero phpwcms, published on 3 Jun 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-5498 and fix it if it is affected.\n\nWhat it is: CVE-2025-5498 is a medium-severity unsafe deserialization vulnerability in slackero phpwcms, published on 3 Jun 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5498 exists.\n\nAffected product: slackero phpwcms. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-5498/ (Markdown: https://insights.sbomify.com/CVE-2025-5498/index.md)","id":"CVE-2025-5498","markdown":"https://insights.sbomify.com/CVE-2025-5498/index.md","name":"CVE-2025-5498","record":{"aliases":["GHSA-5fmq-4fvm-96qg"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"phpwcms CMS","requires_auth":"low_privilege","summary":"Remote attackers can achieve code execution via unsafe deserialization in the Custom Source Tab, requiring an upgrade to patched versions.","user_interaction":"required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"phpwcms","vendor":"phpwcms"}],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"A vulnerability was found in slackero phpwcms up to 1.9.45/1.10.8. It has been rated as critical. This issue affects the function file_get_contents/is_file of the file include/inc_lib/content/cnt21.readform.inc.php of the component Custom Source Tab. The manipulation of the argument cpage_custom leads to deserialization. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.9.46 and 1.10.9 is able to address this issue. It is recommended to upgrade the affected component.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"slackero phpwcms Custom Source Tab cnt21.readform.inc.php is_file deserialization","id":"CVE-2025-5498","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":0,"n_references":7,"next":{"headline":"slackero phpwcms image_resized.php getimagesize deserialization","id":"CVE-2025-5499"},"packages":[],"prev":{"headline":"slackero phpwcms Feedimport processing.inc.php deserialization","id":"CVE-2025-5497"},"products":["phpwcms"],"published":"2025-06-03","related":[{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2021-36424","kev_date_added":null,"published":"2023-02-03"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2020-21784","kev_date_added":null,"published":"2021-06-24"},{"cvss_score":8.8,"headline":"File upload in n/a","id":"CVE-2021-36426","kev_date_added":null,"published":"2023-02-03"},{"cvss_score":7.5,"headline":"Code injection in n/a","id":"CVE-2006-7019","kev_date_added":null,"published":"2007-02-15"},{"cvss_score":6.9,"headline":"slackero phpwcms image_resized.php getimagesize deserialization","id":"CVE-2025-5499","kev_date_added":null,"published":"2025-06-03"},{"cvss_score":6.3,"headline":"slackero phpwcms sql injection","id":"CVE-2021-4301","kev_date_added":null,"published":"2023-01-07"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2020-19855","kev_date_added":null,"published":"2021-09-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-03","vendors":["slackero"]},"summary":"Remote attackers can achieve code execution via unsafe deserialization in the Custom Source Tab, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2025-5498/"}