# CVE-2025-5498: slackero phpwcms Custom Source Tab cnt21.readform.inc.php is_file deserialization

> Remote attackers can achieve code execution via unsafe deserialization in the Custom Source Tab, requiring an upgrade to patched versions.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 3 Jun 2025
- **Updated:** 3 Jun 2025
- **Also known as:** GHSA-5fmq-4fvm-96qg

## What is CVE-2025-5498?

CVE-2025-5498 is a medium-severity unsafe deserialization vulnerability in slackero phpwcms, published on 3 Jun 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in slackero phpwcms up to 1.9.45/1.10.8. It has been rated as critical. This issue affects the function file_get_contents/is_file of the file include/inc_lib/content/cnt21.readform.inc.php of the component Custom Source Tab. The manipulation of the argument cpage_custom leads to deserialization. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.9.46 and 1.10.9 is able to address this issue. It is recommended to upgrade the affected component.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-5498?

It affects 1 product.


Products: Phpwcms Phpwcms.

## How do I fix CVE-2025-5498?

No fix has been published for CVE-2025-5498 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-5498 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5498 exists.

## Other vulnerabilities in slackero phpwcms

- [CVE-2021-36424](https://insights.sbomify.com/CVE-2021-36424/): Code injection in n/a (critical 9.8)
- [CVE-2020-21784](https://insights.sbomify.com/CVE-2020-21784/): Code injection in n/a (critical 9.8)
- [CVE-2021-36426](https://insights.sbomify.com/CVE-2021-36426/): File upload in n/a (high 8.8)
- [CVE-2006-7019](https://insights.sbomify.com/CVE-2006-7019/): Code injection in n/a (high 7.5)
- [CVE-2025-5499](https://insights.sbomify.com/CVE-2025-5499/): slackero phpwcms image_resized.php getimagesize deserialization (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-5498 and fix it if it is affected.

What it is: CVE-2025-5498 is a medium-severity unsafe deserialization vulnerability in slackero phpwcms, published on 3 Jun 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5498 exists.

Affected product: slackero phpwcms. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-5498/ (Markdown: https://insights.sbomify.com/CVE-2025-5498/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-5498
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-5498
- OSV: https://osv.dev/vulnerability/CVE-2025-5498

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-5498/
Summaries are generated and may contain mistakes; the official description above is the record.
