# CVE-2025-54988: Apache Tika PDF parser module: XXE vulnerability in PDFParser's handling of XFA


- **Severity:** High 8.4 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Aug 2025
- **Updated:** 26 Feb 2026
- **Also known as:** DEBIAN-CVE-2025-54988, GHSA-p72g-pv48-7w9x, MINI-3m3r-3cr9-jr5g, MINI-797w-jf5h-wfww, MINI-cpw7-fq7j-vwhp, MINI-f842-4fjq-gv2w, MINI-hr43-84m4-6prv, MINI-j7rm-24wr-x664, MINI-m5px-gv3h-3r29, MINI-mwq9-pmvv-wm9j, MINI-r869-5chc-65rf, MINI-rcpq-2qf3-8574, MINI-w8vw-vqc3-p483, ROOT-APP-MAVEN-CVE-2025-54988, UBUNTU-CVE-2025-54988

## What is CVE-2025-54988?

CVE-2025-54988 is a high-severity vulnerability in Apache Tika PDF parser module, published on 20 Aug 2025. 

### Official description

Critical XXE in Apache Tika (tika-parser-pdf-module) in Apache Tika 1.13 through and including 3.2.1 on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF. An attacker may be able to read sensitive data or trigger malicious requests to internal resources or third-party servers. Note that the tika-parser-pdf-module is used as a dependency in several Tika packages including at least: tika-parsers-standard-modules, tika-parsers-standard-package, tika-app, tika-grpc and tika-server-standard.

Users are recommended to upgrade to version 3.2.2, which fixes this issue.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2025-54988?

4 open source packages ship an affected version, including org.apache.tika:tika-parser-pdf-module and org.apache.tika:tika-parsers. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tika:tika-parser-pdf-module` | Maven | From 1.13 | 3.2.2 |
| `org.apache.tika:tika-parser-pdf-module` | Maven | From 1.13 | 3.2.2 |
| `org.apache.tika:tika-parsers` | Maven | From 1.13 | 2.0.0-ALPHA |
| `org.apache.tika:tika-parsers` | Maven | From 1.13 | 2.0.0-ALPHA |

Products: Apache Tika.

## How do I fix CVE-2025-54988?

Upgrade org.apache.tika:tika-parser-pdf-module to 3.2.2 or later.

## Is CVE-2025-54988 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54988 exists.

Public exploit code:

- A PDF generator for CVE-2025-54988 (github_poc): https://github.com/mgthuramoemyint/POC-CVE-2025-54988
- Elasticsearch ingest-attachment Apache Tika XFA XXE Local File Read (metasploit)
- Creating a vulnerable instance to test against (github_poc): https://github.com/galoryber/cve-2025-54988-VulnTikaProject
- Apache Tika - XXE Injection (nuclei): http/cves/2025/CVE-2025-54988.yaml

## Other vulnerabilities in Apache Tika PDF parser module

- [CVE-2019-10088](https://insights.sbomify.com/CVE-2019-10088/): Allocation of Resources Without Limits or Throttling in Apache Tika (high 8.8)
- [CVE-2025-66516](https://insights.sbomify.com/CVE-2025-66516/): Apache Tika has XXE vulnerability (high 8.4)
- [CVE-2018-1335](https://insights.sbomify.com/CVE-2018-1335/): Command injection in org.apache.tika:tika-core (high 8.1)
- [CVE-2019-10094](https://insights.sbomify.com/CVE-2019-10094/): Allocation of Resources Without Limits or Throttling in Apache Tika (high 7.8)
- [CVE-2016-4434](https://insights.sbomify.com/CVE-2016-4434/): Apache Tika does not properly initialize the XML parser or choose handlers (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54988 and fix it if it is affected.

What it is: CVE-2025-54988 is a high-severity vulnerability in Apache Tika PDF parser module, published on 20 Aug 2025. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54988 exists.

Affected packages and fixed versions:
- org.apache.tika:tika-parser-pdf-module (Maven): affected from 1.13; fixed in 3.2.2
- org.apache.tika:tika-parser-pdf-module (Maven): affected from 1.13; fixed in 3.2.2
- org.apache.tika:tika-parsers (Maven): affected from 1.13; fixed in 2.0.0-ALPHA
- org.apache.tika:tika-parsers (Maven): affected from 1.13; fixed in 2.0.0-ALPHA

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54988/ (Markdown: https://insights.sbomify.com/CVE-2025-54988/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54988
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54988
- OSV: https://osv.dev/vulnerability/CVE-2025-54988

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54988/
Summaries are generated and may contain mistakes; the official description above is the record.
