# CVE-2025-54990: XWiki AdminTools application doesn't set permissions on the AdminTools space

> Non-admin users can access the AdminTools.SpammedPages page due to missing view restrictions, potentially exposing administrative interface elements.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Nov 2025
- **Updated:** 19 Nov 2025
- **Also known as:** GHSA-v7r8-8p5c-h4xw

## What is CVE-2025-54990?

CVE-2025-54990 is a medium-severity missing authorization vulnerability in xwikisas application-admintools, published on 18 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki AdminTools integrates administrative tools for managing a running XWiki instance. Prior to version 1.1, users without admin rights have access to AdminTools.SpammedPages. View rights are not restricted only to admin users for AdminTools.SpammedPages. While no data is visible to non admin users, the page is still accessible. This issue has been patched in version 1.1. A workaround involves setting the view rights for the AdminTools space to be only available for the XWikiAdminGroup.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2025-54990?

2 open source packages ship an affected version, including com.xwiki.admintools:application-admintools.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.xwiki.admintools:application-admintools` | Maven | All versions | 1.1 |
| `com.xwiki.admintools:application-admintools` | Maven | All versions | 1.1 |

## How do I fix CVE-2025-54990?

Upgrade com.xwiki.admintools:application-admintools to 1.1 or later.

## Is CVE-2025-54990 being exploited?

There is no known exploitation of CVE-2025-54990 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54990 and fix it if it is affected.

What it is: CVE-2025-54990 is a medium-severity missing authorization vulnerability in xwikisas application-admintools, published on 18 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-54990 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.xwiki.admintools:application-admintools (Maven): affected all versions; fixed in 1.1
- com.xwiki.admintools:application-admintools (Maven): affected all versions; fixed in 1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54990/ (Markdown: https://insights.sbomify.com/CVE-2025-54990/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54990
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54990
- OSV: https://osv.dev/vulnerability/CVE-2025-54990

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54990/
Summaries are generated and may contain mistakes; the official description above is the record.
