# CVE-2025-54992: OpenKilda XXE in SAML configuration

> Unauthenticated attackers can exploit an XXE vulnerability in the SAML configuration to exfiltrate sensitive information from the OpenKilda UI instance.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 11 Aug 2025
- **Updated:** 12 Aug 2025
- **Also known as:** GHSA-43rg-6r66-6hr7

## What is CVE-2025-54992?

CVE-2025-54992 is a medium-severity vulnerability in telstra open-kilda, published on 11 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenKilda is an open-source OpenFlow controller. Prior to version 1.164.0, an XML external entity (XXE) injection vulnerability was found in OpenKilda which in combination with GHSL-2025-024 allows unauthenticated attackers to exfiltrate information from the instance where the OpenKilda UI is running. This issue may lead to Information disclosure. This issue has been patched in version 1.164.0.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2025-54992?


## How do I fix CVE-2025-54992?

No fix has been published for CVE-2025-54992 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-54992 being exploited?

There is no known exploitation of CVE-2025-54992 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54992 and fix it if it is affected.

What it is: CVE-2025-54992 is a medium-severity vulnerability in telstra open-kilda, published on 11 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-54992 in the wild and no public exploit code.

Affected product: telstra open-kilda. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54992/ (Markdown: https://insights.sbomify.com/CVE-2025-54992/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54992
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54992
- OSV: https://osv.dev/vulnerability/CVE-2025-54992

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54992/
Summaries are generated and may contain mistakes; the official description above is the record.
