# CVE-2025-54996: OpenBao Root Namespace Operator May Elevate Token Privileges

> Root namespace operators can escalate privileges to the global root policy, bypassing intended restrictions on high-privilege access.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Aug 2025
- **Updated:** 11 Aug 2025
- **Also known as:** BIT-openbao-2025-54996, GHSA-vf84-mxrq-crqc, GO-2025-3857

## What is CVE-2025-54996?

CVE-2025-54996 is a high-severity vulnerability in openbao, published on 9 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

OpenBao exists to provide a software solution to manage, store, and distribute sensitive data including secrets, certificates, and keys. In versions 2.3.1 and below, accounts with access to highly-privileged identity entity systems in root namespaces were able to increase their scope directly to the root policy. While the identity system allowed adding arbitrary policies, which in turn could contain capability grants on arbitrary paths, the root policy was restricted to manual generation using unseal or recovery key shares. The global root policy was not accessible from child namespaces. This issue is fixed in version 2.3.2. To workaround this vulnerability, use of denied_parameters in any policy which has access to the affected identity endpoints (on identity entities) may be sufficient to prohibit this type of attack.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2025-54996?

6 open source packages ship an affected version, including github.com/openbao/openbao and openbao. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20250806193240-9b0b5d4f345f |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20250806193240-9b0b5d4f345f |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20250806193240-9b0b5d4f345f |
| `github.com/openbao/openbao` | Go | From 0.1.0 | 2.3.2 |
| `github.com/openbao/openbao` | Go | From 0.1.0 | 2.3.2 |
| `openbao` | Bitnami | All versions | 0.0.0-20250806193240-9b0b5d4f345f, 2.3.2 |

Products: Openbao Openbao.

## How do I fix CVE-2025-54996?

Upgrade github.com/openbao/openbao to a fixed version for your release line: 0.0.0-20250806193240-9b0b5d4f345f or 2.3.2.

## Is CVE-2025-54996 being exploited?

There is no known exploitation of CVE-2025-54996 in the wild and no public exploit code.

## Other vulnerabilities in openbao

- [CVE-2026-33757](https://insights.sbomify.com/CVE-2026-33757/): OpenBao lacks user confirmation for OIDC direct callback mode (critical 9.6)
- [CVE-2026-33758](https://insights.sbomify.com/CVE-2026-33758/): OpenBao has Reflected XSS in its OIDC authentication error message (critical 9.4)
- [CVE-2025-54997](https://insights.sbomify.com/CVE-2025-54997/): OpenBao: Privileged Operator May Execute Code on the Underlying Host (critical 9.1)
- [CVE-2025-64761](https://insights.sbomify.com/CVE-2025-64761/): OpenBao Privileged Operator Identity Group Root Escalation (high 7.5)
- [CVE-2025-59043](https://insights.sbomify.com/CVE-2025-59043/): OpenBao vulnerable to denial of service via malicious JSON request processing (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54996 and fix it if it is affected.

What it is: CVE-2025-54996 is a high-severity vulnerability in openbao, published on 9 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-54996 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20250806193240-9b0b5d4f345f
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20250806193240-9b0b5d4f345f
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20250806193240-9b0b5d4f345f
- github.com/openbao/openbao (Go): affected from 0.1.0; fixed in 2.3.2
- github.com/openbao/openbao (Go): affected from 0.1.0; fixed in 2.3.2
- openbao (Bitnami): affected all versions; fixed in 0.0.0-20250806193240-9b0b5d4f345f, 2.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54996/ (Markdown: https://insights.sbomify.com/CVE-2025-54996/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54996
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54996
- OSV: https://osv.dev/vulnerability/CVE-2025-54996

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54996/
Summaries are generated and may contain mistakes; the official description above is the record.
