CVE-2025-54997 OpenBao: Privileged Operator May Execute Code on the Underlying Host
Privileged operators can bypass security restrictions to execute code on the host via audit log prefix manipulation in OpenBao.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-54997?
CVE-2025-54997 is a critical code injection vulnerability in openbao, published on 9 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
OpenBao exists to provide a software solution to manage, store, and distribute sensitive data including secrets, certificates, and keys. In versions 2.3.1 and below, some OpenBao deployments intentionally limit privileged API operators from executing system code or making network connections. However, these operators can bypass both restrictions through the audit subsystem by manipulating log prefixes. This allows unauthorized code execution and network access that violates the intended security model. This issue is fixed in version 2.3.2. To workaround, users can block access to sys/audit/* endpoints using explicit deny policies, but root operators cannot be restricted this way.
Weakness: CWE-94
Which versions are affected by CVE-2025-54997?
6 open source packages ship an affected version, including github.com/openbao/openbao and openbao. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/openbao/openbao Go | All versions | 0.0.0-20250806194004-a14053c9679d |
github.com/openbao/openbao Go | All versions | 0.0.0-20250806194004-a14053c9679d |
github.com/openbao/openbao Go | All versions | 0.0.0-20250806194004-a14053c9679d |
github.com/openbao/openbao Go | From 0.1.0 | 2.3.2 |
github.com/openbao/openbao Go | From 0.1.0 | 2.3.2 |
openbao Bitnami | All versions | 0.0.0-20250806194004-a14053c9679d, 2.3.2 |
Products include Openbao Openbao.
How do I fix CVE-2025-54997?
Upgrade github.com/openbao/openbao to a fixed version for your release line: 0.0.0-20250806194004-a14053c9679d or 2.3.2.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2025-54997 being exploited?
There is no known exploitation of CVE-2025-54997 in the wild and no public exploit code.
Other vulnerabilities in openbao
- CVE-2026-33757 OpenBao lacks user confirmation for OIDC direct callback mode
- CVE-2026-33758 OpenBao has Reflected XSS in its OIDC authentication error message
- CVE-2025-64761 OpenBao Privileged Operator Identity Group Root Escalation
- CVE-2025-59043 OpenBao vulnerable to denial of service via malicious JSON request processing
- CVE-2025-54996 OpenBao Root Namespace Operator May Elevate Token Privileges
Sources
Also known as BIT-openbao-2025-54997, GHSA-xp75-r577-cvhp, GO-2025-3858.