# CVE-2025-54997: OpenBao: Privileged Operator May Execute Code on the Underlying Host

> Privileged operators can bypass security restrictions to execute code on the host via audit log prefix manipulation in OpenBao.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Aug 2025
- **Updated:** 11 Aug 2025
- **Also known as:** BIT-openbao-2025-54997, GHSA-xp75-r577-cvhp, GO-2025-3858

## What is CVE-2025-54997?

CVE-2025-54997 is a critical code injection vulnerability in openbao, published on 9 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

OpenBao exists to provide a software solution to manage, store, and distribute sensitive data including secrets, certificates, and keys. In versions 2.3.1 and below, some OpenBao deployments intentionally limit privileged API operators from executing system code or making network connections. However, these operators can bypass both restrictions through the audit subsystem by manipulating log prefixes. This allows unauthorized code execution and network access that violates the intended security model. This issue is fixed in version 2.3.2. To workaround, users can block access to sys/audit/* endpoints using explicit deny policies, but root operators cannot be restricted this way.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2025-54997?

6 open source packages ship an affected version, including github.com/openbao/openbao and openbao. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20250806194004-a14053c9679d |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20250806194004-a14053c9679d |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20250806194004-a14053c9679d |
| `github.com/openbao/openbao` | Go | From 0.1.0 | 2.3.2 |
| `github.com/openbao/openbao` | Go | From 0.1.0 | 2.3.2 |
| `openbao` | Bitnami | All versions | 0.0.0-20250806194004-a14053c9679d, 2.3.2 |

Products: Openbao Openbao.

## How do I fix CVE-2025-54997?

Upgrade github.com/openbao/openbao to a fixed version for your release line: 0.0.0-20250806194004-a14053c9679d or 2.3.2.

## Is CVE-2025-54997 being exploited?

There is no known exploitation of CVE-2025-54997 in the wild and no public exploit code.

## Other vulnerabilities in openbao

- [CVE-2026-33757](https://insights.sbomify.com/CVE-2026-33757/): OpenBao lacks user confirmation for OIDC direct callback mode (critical 9.6)
- [CVE-2026-33758](https://insights.sbomify.com/CVE-2026-33758/): OpenBao has Reflected XSS in its OIDC authentication error message (critical 9.4)
- [CVE-2025-64761](https://insights.sbomify.com/CVE-2025-64761/): OpenBao Privileged Operator Identity Group Root Escalation (high 7.5)
- [CVE-2025-59043](https://insights.sbomify.com/CVE-2025-59043/): OpenBao vulnerable to denial of service via malicious JSON request processing (high 7.5)
- [CVE-2025-54996](https://insights.sbomify.com/CVE-2025-54996/): OpenBao Root Namespace Operator May Elevate Token Privileges (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54997 and fix it if it is affected.

What it is: CVE-2025-54997 is a critical code injection vulnerability in openbao, published on 9 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-54997 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20250806194004-a14053c9679d
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20250806194004-a14053c9679d
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20250806194004-a14053c9679d
- github.com/openbao/openbao (Go): affected from 0.1.0; fixed in 2.3.2
- github.com/openbao/openbao (Go): affected from 0.1.0; fixed in 2.3.2
- openbao (Bitnami): affected all versions; fixed in 0.0.0-20250806194004-a14053c9679d, 2.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54997/ (Markdown: https://insights.sbomify.com/CVE-2025-54997/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54997
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54997
- OSV: https://osv.dev/vulnerability/CVE-2025-54997

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54997/
Summaries are generated and may contain mistakes; the official description above is the record.
