# CVE-2025-55000: OpenBao TOTP Secrets Engine Enables Code Reuse

> OpenBao's TOTP engine allows code reuse due to normalization flaws, enabling attackers to bypass single-use restrictions if they can submit valid codes.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Aug 2025
- **Updated:** 11 Aug 2025
- **Also known as:** BIT-openbao-2025-55000, GHSA-f7c3-mhj2-9pvg, GO-2025-3853

## What is CVE-2025-55000?

CVE-2025-55000 is a medium-severity vulnerability in openbao, published on 9 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenBao exists to provide a software solution to manage, store, and distribute sensitive data including secrets, certificates, and keys. In versions 0.1.0 through 2.3.1, OpenBao's TOTP secrets engine could accept valid codes multiple times rather than strictly-once. This was caused by unexpected normalization in the underlying TOTP library. To work around, ensure that all codes are first normalized before submitting to the OpenBao endpoint. TOTP code verification is a privileged action; only trusted systems should be verifying codes.

Weakness: CWE-156 (Improper Neutralization of Whitespace)

## Which versions are affected by CVE-2025-55000?

6 open source packages ship an affected version, including github.com/openbao/openbao and openbao. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20250806193153-183891f8d535 |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20250806193153-183891f8d535 |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20250806193153-183891f8d535 |
| `github.com/openbao/openbao` | Go | From 0.1.0 | 2.3.2 |
| `github.com/openbao/openbao` | Go | From 0.1.0 | 2.3.2 |
| `openbao` | Bitnami | All versions | 0.0.0-20250806193153-183891f8d535, 2.3.2 |

Products: Openbao Openbao.

## How do I fix CVE-2025-55000?

Upgrade github.com/openbao/openbao to a fixed version for your release line: 0.0.0-20250806193153-183891f8d535 or 2.3.2.

## Is CVE-2025-55000 being exploited?

There is no known exploitation of CVE-2025-55000 in the wild and no public exploit code.

## Other vulnerabilities in openbao

- [CVE-2026-33757](https://insights.sbomify.com/CVE-2026-33757/): OpenBao lacks user confirmation for OIDC direct callback mode (critical 9.6)
- [CVE-2026-33758](https://insights.sbomify.com/CVE-2026-33758/): OpenBao has Reflected XSS in its OIDC authentication error message (critical 9.4)
- [CVE-2025-54997](https://insights.sbomify.com/CVE-2025-54997/): OpenBao: Privileged Operator May Execute Code on the Underlying Host (critical 9.1)
- [CVE-2025-64761](https://insights.sbomify.com/CVE-2025-64761/): OpenBao Privileged Operator Identity Group Root Escalation (high 7.5)
- [CVE-2025-59043](https://insights.sbomify.com/CVE-2025-59043/): OpenBao vulnerable to denial of service via malicious JSON request processing (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55000 and fix it if it is affected.

What it is: CVE-2025-55000 is a medium-severity vulnerability in openbao, published on 9 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-55000 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20250806193153-183891f8d535
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20250806193153-183891f8d535
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20250806193153-183891f8d535
- github.com/openbao/openbao (Go): affected from 0.1.0; fixed in 2.3.2
- github.com/openbao/openbao (Go): affected from 0.1.0; fixed in 2.3.2
- openbao (Bitnami): affected all versions; fixed in 0.0.0-20250806193153-183891f8d535, 2.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55000/ (Markdown: https://insights.sbomify.com/CVE-2025-55000/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55000
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55000
- OSV: https://osv.dev/vulnerability/CVE-2025-55000

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55000/
Summaries are generated and may contain mistakes; the official description above is the record.
