CVE-2025-55001 OpenBao LDAP MFA Enforcement Bypass When Using Username As Alias
Attackers can bypass MFA requirements in OpenBao by exploiting username normalization flaws when the username_as_alias parameter is enabled.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-55001?
CVE-2025-55001 is a medium-severity authentication bypass vulnerability in openbao, published on 9 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
OpenBao exists to provide a software solution to manage, store, and distribute sensitive data including secrets, certificates, and keys. In versions 2.3.1 and below, OpenBao allowed the assignment of policies and MFA attribution based upon entity aliases, chosen by the underlying auth method. When the username_as_alias=true parameter in the LDAP auth method was in use, the caller-supplied username was used verbatim without normalization, allowing an attacker to bypass alias-specific MFA requirements. This issue was fixed in version 2.3.2. To work around this, remove all usage of the username_as_alias=true parameter and update any entity aliases accordingly.
Weakness: CWE-156
Which versions are affected by CVE-2025-55001?
6 open source packages ship an affected version, including github.com/openbao/openbao and openbao. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/openbao/openbao Go | All versions | 0.0.0-20250807212521-c52795c1ef74 |
github.com/openbao/openbao Go | All versions | 0.0.0-20250807212521-c52795c1ef74 |
github.com/openbao/openbao Go | All versions | 0.0.0-20250807212521-c52795c1ef74 |
github.com/openbao/openbao Go | From 0.1.0 | 2.3.2 |
github.com/openbao/openbao Go | From 0.1.0 | 2.3.2 |
openbao Bitnami | All versions | 0.0.0-20250807212521-c52795c1ef74, 2.3.2 |
Products include Openbao Openbao.
How do I fix CVE-2025-55001?
Upgrade github.com/openbao/openbao to a fixed version for your release line: 0.0.0-20250807212521-c52795c1ef74 or 2.3.2.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2025-55001 being exploited?
There is no known exploitation of CVE-2025-55001 in the wild and no public exploit code.
Other vulnerabilities in openbao
- CVE-2026-33757 OpenBao lacks user confirmation for OIDC direct callback mode
- CVE-2026-33758 OpenBao has Reflected XSS in its OIDC authentication error message
- CVE-2025-54997 OpenBao: Privileged Operator May Execute Code on the Underlying Host
- CVE-2025-64761 OpenBao Privileged Operator Identity Group Root Escalation
- CVE-2025-59043 OpenBao vulnerable to denial of service via malicious JSON request processing
Sources
Also known as BIT-openbao-2025-55001, GHSA-2q8q-8fgw-9p6p, GO-2025-3859.