CVE-2025-55003 OpenBao Login MFA Bypasses Rate Limiting and TOTP Token Reuse
Attackers can bypass MFA rate limiting and reuse TOTP codes in OpenBao due to whitespace normalization flaws, compromising authentication security.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-55003?
CVE-2025-55003 is a medium-severity vulnerability in openbao, published on 9 Aug 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
OpenBao exists to provide a software solution to manage, store, and distribute sensitive data including secrets, certificates, and keys. In versions 2.3.1 and below, OpenBao's Login Multi-Factor Authentication (MFA) system allows enforcing MFA using Time-based One Time Password (TOTP). Due to normalization applied by the underlying TOTP library, codes were accepted which could contain whitespace; this whitespace could bypass internal rate limiting of the MFA method and allow reuse of existing MFA codes. This issue was fixed in version 2.3.2. To work around this, use of rate-limiting quotas can limit an attacker's ability to exploit this: https://openbao.org/api-docs/system/rate-limit-quotas/.
Weakness: CWE-307
Which versions are affected by CVE-2025-55003?
6 open source packages ship an affected version, including github.com/openbao/openbao and openbao. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/openbao/openbao Go | All versions | 0.0.0-20250807113757-8340a6918f6c |
github.com/openbao/openbao Go | All versions | 0.0.0-20250807113757-8340a6918f6c |
github.com/openbao/openbao Go | All versions | 0.0.0-20250807113757-8340a6918f6c |
github.com/openbao/openbao Go | From 0.1.0 | 2.3.2 |
github.com/openbao/openbao Go | From 0.1.0 | 2.3.2 |
openbao Bitnami | All versions | 0.0.0-20250807113757-8340a6918f6c, 2.3.2 |
Products include Openbao Openbao.
How do I fix CVE-2025-55003?
Upgrade github.com/openbao/openbao to a fixed version for your release line: 0.0.0-20250807113757-8340a6918f6c or 2.3.2.
Is CVE-2025-55003 being exploited?
There is no known exploitation of CVE-2025-55003 in the wild and no public exploit code.
Other vulnerabilities in openbao
- CVE-2026-33757 OpenBao lacks user confirmation for OIDC direct callback mode
- CVE-2026-33758 OpenBao has Reflected XSS in its OIDC authentication error message
- CVE-2025-54997 OpenBao: Privileged Operator May Execute Code on the Underlying Host
- CVE-2025-64761 OpenBao Privileged Operator Identity Group Root Escalation
- CVE-2025-59043 OpenBao vulnerable to denial of service via malicious JSON request processing
Sources
Also known as BIT-openbao-2025-55003, GHSA-rxp7-9q75-vj3p, GO-2025-3856.