# CVE-2025-55004: ImageMagick: heap-buffer overflow read in MNG magnification with alpha

> Attacker can leak memory contents via heap-buffer overflow in ImageMagick's MNG image magnification handling.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Aug 2025
- **Updated:** 13 Aug 2025
- **Also known as:** CLSA-2025-1762544876, CLSA-2026-1769187509, DEBIAN-CVE-2025-55004, GHSA-cjc8-g9w8-chfw, JLSEC-2026-919, MINI-gg5q-3v9p-668g, UBUNTU-CVE-2025-55004

## What is CVE-2025-55004?

CVE-2025-55004 is a high-severity memory corruption vulnerability in Imagemagick Imagemagick, published on 13 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to version 7.1.2-1, ImageMagick is vulnerable to heap-buffer overflow read around the handling of images with separate alpha channels when performing image magnification in ReadOneMNGIMage. This can likely be used to leak subsequent memory contents into the output image. This issue has been patched in version 7.1.2-1.

Weakness: CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2025-55004?

36 open source packages ship an affected version, including Magick.NET-Q16-AnyCPU, Magick.NET-Q16-HDRI-AnyCPU and Magick.NET-Q16-HDRI-OpenMP-arm64. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Magick.NET-Q16-AnyCPU` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q16-AnyCPU` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q16-HDRI-AnyCPU` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q16-HDRI-AnyCPU` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q16-HDRI-OpenMP-arm64` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q16-HDRI-OpenMP-arm64` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q16-HDRI-OpenMP-x64` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q16-HDRI-OpenMP-x64` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q16-HDRI-arm64` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q16-HDRI-arm64` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q16-HDRI-x64` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q16-HDRI-x64` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q16-HDRI-x86` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q16-HDRI-x86` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q16-OpenMP-arm64` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q16-OpenMP-arm64` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q16-OpenMP-x64` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q16-OpenMP-x64` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q16-arm64` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q16-arm64` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q16-x64` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q16-x64` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q16-x86` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q16-x86` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q8-AnyCPU` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q8-AnyCPU` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q8-OpenMP-arm64` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q8-OpenMP-arm64` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q8-OpenMP-x64` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q8-OpenMP-x64` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q8-arm64` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q8-arm64` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q8-x64` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q8-x64` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q8-x86` | NuGet | All versions | 14.8.0 |
| `Magick.NET-Q8-x86` | NuGet | All versions | 14.8.0 |

Products: Imagemagick Imagemagick.

## How do I fix CVE-2025-55004?

Upgrade Magick.NET-Q16-AnyCPU to 14.8.0 or later.

## Is CVE-2025-55004 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55004 exists.

## Other vulnerabilities in Imagemagick Imagemagick

- [CVE-2019-19952](https://insights.sbomify.com/CVE-2019-19952/): Use after free in n/a (critical 9.8)
- [CVE-2018-16328](https://insights.sbomify.com/CVE-2018-16328/): Null dereference in n/a (critical 9.8)
- [CVE-2018-16329](https://insights.sbomify.com/CVE-2018-16329/): Null dereference in n/a (critical 9.8)
- [CVE-2017-18210](https://insights.sbomify.com/CVE-2017-18210/): Null dereference in n/a (critical 9.8)
- [CVE-2017-14138](https://insights.sbomify.com/CVE-2017-14138/): Denial of service in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55004 and fix it if it is affected.

What it is: CVE-2025-55004 is a high-severity memory corruption vulnerability in Imagemagick Imagemagick, published on 13 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55004 exists.

Affected packages and fixed versions:
- Magick.NET-Q16-AnyCPU (NuGet): affected all versions; fixed in 14.8.0
- Magick.NET-Q16-AnyCPU (NuGet): affected all versions; fixed in 14.8.0
- Magick.NET-Q16-HDRI-AnyCPU (NuGet): affected all versions; fixed in 14.8.0
- Magick.NET-Q16-HDRI-AnyCPU (NuGet): affected all versions; fixed in 14.8.0
- Magick.NET-Q16-HDRI-OpenMP-arm64 (NuGet): affected all versions; fixed in 14.8.0
- Magick.NET-Q16-HDRI-OpenMP-arm64 (NuGet): affected all versions; fixed in 14.8.0
- Magick.NET-Q16-HDRI-OpenMP-x64 (NuGet): affected all versions; fixed in 14.8.0
- Magick.NET-Q16-HDRI-OpenMP-x64 (NuGet): affected all versions; fixed in 14.8.0
- Magick.NET-Q16-HDRI-arm64 (NuGet): affected all versions; fixed in 14.8.0
- Magick.NET-Q16-HDRI-arm64 (NuGet): affected all versions; fixed in 14.8.0
- Magick.NET-Q16-HDRI-x64 (NuGet): affected all versions; fixed in 14.8.0
- Magick.NET-Q16-HDRI-x64 (NuGet): affected all versions; fixed in 14.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55004/ (Markdown: https://insights.sbomify.com/CVE-2025-55004/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55004
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55004
- OSV: https://osv.dev/vulnerability/CVE-2025-55004

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55004/
Summaries are generated and may contain mistakes; the official description above is the record.
