# CVE-2025-55007: Knowage vulnerable to server-side request forgery

> Attackers can send arbitrary requests to internal hosts, enabling network scanning, though response data is not readable.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 1 Sep 2025
- **Updated:** 2 Sep 2025
- **Also known as:** GHSA-7f6m-ph57-52w6

## What is CVE-2025-55007?

CVE-2025-55007 is a low-severity server-side request forgery vulnerability in KnowageLabs Knowage-Server, published on 1 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Knowage is an open source analytics and business intelligence suite. Prior to version 8.1.37, Knowage is vulnerable to server-side request forgery. The vulnerability allows attackers to send requests to arbitrary hosts/paths. Since the attacker is not able to read the response, the impact of this vulnerability is limited. However, an attacker could be able to leverage this vulnerability to scan the internal network. This issue has been patched in version 8.1.37.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-55007?

It affects 1 product.


Products: Eng Knowage.

## How do I fix CVE-2025-55007?

No fix has been published for CVE-2025-55007 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-55007 being exploited?

There is no known exploitation of CVE-2025-55007 in the wild and no public exploit code.

## Other vulnerabilities in KnowageLabs Knowage-Server

- [CVE-2023-38702](https://insights.sbomify.com/CVE-2023-38702/): Knowage Server vulnerable to path traversal via upload functionality (critical 10.0)
- [CVE-2019-13188](https://insights.sbomify.com/CVE-2019-13188/): Auth bypass in n/a (critical 9.8)
- [CVE-2025-59954](https://insights.sbomify.com/CVE-2025-59954/): Knowage Contains a Remote Code Execution Vulnerability (critical 9.3)
- [CVE-2021-30055](https://insights.sbomify.com/CVE-2021-30055/): SQL injection in n/a (high 8.8)
- [CVE-2019-13348](https://insights.sbomify.com/CVE-2019-13348/): Information disclosure in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55007 and fix it if it is affected.

What it is: CVE-2025-55007 is a low-severity server-side request forgery vulnerability in KnowageLabs Knowage-Server, published on 1 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-55007 in the wild and no public exploit code.

Affected product: KnowageLabs Knowage-Server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55007/ (Markdown: https://insights.sbomify.com/CVE-2025-55007/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55007
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55007
- OSV: https://osv.dev/vulnerability/CVE-2025-55007

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55007/
Summaries are generated and may contain mistakes; the official description above is the record.
