# CVE-2025-55008: AuthKit React Router: Sensitive auth data rendered in HTML

> Attackers can view sensitive authentication tokens in browser HTML due to improper data exposure in the AuthKit React Router library.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Aug 2025
- **Updated:** 11 Aug 2025
- **Also known as:** GHSA-vqvc-9q8x-vmq6

## What is CVE-2025-55008?

CVE-2025-55008 is a high-severity vulnerability in workos authkit-react-router, published on 9 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The AuthKit library for React Router 7+ provides helpers for authentication and session management using WorkOS & AuthKit with React Router. In versions 0.6.1 and below, @workos-inc/authkit-react-router exposed sensitive authentication artifacts — specifically sealedSession and accessToken by returning them from the authkitLoader. This caused them to be rendered into the browser HTML. This issue is fixed in version 0.7.0.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-55008?

2 open source packages ship an affected version, including @workos-inc/authkit-react-router.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@workos-inc/authkit-react-router` | npm | All versions | 0.7.0 |
| `@workos-inc/authkit-react-router` | npm | All versions | 0.7.0 |

## How do I fix CVE-2025-55008?

Upgrade @workos-inc/authkit-react-router to 0.7.0 or later.

## Is CVE-2025-55008 being exploited?

There is no known exploitation of CVE-2025-55008 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55008 and fix it if it is affected.

What it is: CVE-2025-55008 is a high-severity vulnerability in workos authkit-react-router, published on 9 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-55008 in the wild and no public exploit code.

Affected packages and fixed versions:
- @workos-inc/authkit-react-router (npm): affected all versions; fixed in 0.7.0
- @workos-inc/authkit-react-router (npm): affected all versions; fixed in 0.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55008/ (Markdown: https://insights.sbomify.com/CVE-2025-55008/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55008
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55008
- OSV: https://osv.dev/vulnerability/CVE-2025-55008

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55008/
Summaries are generated and may contain mistakes; the official description above is the record.
