# CVE-2025-55012: Zed AI Agent Remote Code Execution

> An AI agent in the Zed editor could bypass permission checks to execute arbitrary commands on a victim's machine.

- **Severity:** High 8.5 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 11 Aug 2025
- **Updated:** 12 Aug 2025
- **Also known as:** GHSA-x34m-39xw-g2wr

## What is CVE-2025-55012?

CVE-2025-55012 is a high-severity authentication bypass vulnerability in zed-industries zed, published on 11 Aug 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Zed is a multiplayer code editor. Prior to version 0.197.3, in the Zed Agent Panel allowed for an AI agent to achieve Remote Code Execution (RCE) by bypassing user permission checks. An AI Agent could have exploited a permissions bypass vulnerability to create or modify a project-specific configuration file, leading to the execution of arbitrary commands on a victim's machine without the explicit approval that would otherwise be required. This vulnerability has been patched in version 0.197.3. A workaround for this issue involves either avoid sending prompts to the Agent Panel, or to limit the AI Agent's file system access.

Weakness: CWE-288 (Authentication Bypass Using an Alternate Path or Channel), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2025-55012?


## How do I fix CVE-2025-55012?

No fix has been published for CVE-2025-55012 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-55012 being exploited?

There is no known exploitation of CVE-2025-55012 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55012 and fix it if it is affected.

What it is: CVE-2025-55012 is a high-severity authentication bypass vulnerability in zed-industries zed, published on 11 Aug 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-55012 in the wild and no public exploit code.

Affected product: zed-industries zed. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55012/ (Markdown: https://insights.sbomify.com/CVE-2025-55012/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55012
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55012
- OSV: https://osv.dev/vulnerability/CVE-2025-55012

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55012/
Summaries are generated and may contain mistakes; the official description above is the record.
