# CVE-2025-55013: Assemblyline 4 Service Client: Arbitrary Write through path traversal in Client code

> A malicious server can force the Assemblyline 4 Service Client to write files to arbitrary locations via path traversal, potentially leading to code execution.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Aug 2025
- **Updated:** 12 Aug 2025
- **Also known as:** GHSA-75jv-vfxf-3865, PYSEC-2026-1194

## What is CVE-2025-55013?

CVE-2025-55013 is a medium-severity path traversal vulnerability in CybercentreCanada assemblyline, published on 9 Aug 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The Assemblyline 4 Service Client interfaces with the API to fetch tasks and publish the result for a service in Assemblyline 4. In versions below 4.6.1.dev138, the Assemblyline 4 Service Client (task_handler.py) accepts a SHA-256 value returned by the service server and uses it directly as a local file name.A malicious or compromised server (or any MITM that can speak to client) can return a path-traversal payload such as `../../../etc/cron.d/evil` and force the client to write the downloaded bytes to an arbitrary location on disk. This is fixed in version 4.6.1.dev138.

Weakness: CWE-23 (Relative Path Traversal)

## Which versions are affected by CVE-2025-55013?

5 open source packages ship an affected version, including assemblyline-service-client.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `assemblyline-service-client` | PyPI | All versions | 4.6.0.stable11, 4.6.1.dev138 |
| `assemblyline-service-client` | PyPI | All versions | 4.6.0.stable11 |
| `assemblyline-service-client` | PyPI | All versions | 4.6.0.stable11 |
| `assemblyline-service-client` | PyPI | From 4.6.1.dev0 | 4.6.1.dev138 |
| `assemblyline-service-client` | PyPI | From 4.6.1.dev0 | 4.6.1.dev138 |

## How do I fix CVE-2025-55013?

Upgrade assemblyline-service-client to a fixed version for your release line: 4.6.0.stable11 or 4.6.1.dev138.

## Is CVE-2025-55013 being exploited?

There is no known exploitation of CVE-2025-55013 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55013 and fix it if it is affected.

What it is: CVE-2025-55013 is a medium-severity path traversal vulnerability in CybercentreCanada assemblyline, published on 9 Aug 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-55013 in the wild and no public exploit code.

Affected packages and fixed versions:
- assemblyline-service-client (PyPI): affected all versions; fixed in 4.6.0.stable11, 4.6.1.dev138
- assemblyline-service-client (PyPI): affected all versions; fixed in 4.6.0.stable11
- assemblyline-service-client (PyPI): affected all versions; fixed in 4.6.0.stable11
- assemblyline-service-client (PyPI): affected from 4.6.1.dev0; fixed in 4.6.1.dev138
- assemblyline-service-client (PyPI): affected from 4.6.1.dev0; fixed in 4.6.1.dev138

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55013/ (Markdown: https://insights.sbomify.com/CVE-2025-55013/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55013
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55013
- OSV: https://osv.dev/vulnerability/CVE-2025-55013

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55013/
Summaries are generated and may contain mistakes; the official description above is the record.
