CVE-2025-55017 Apache IoTDB: Path Traversal Vulnerability
Attackers can exploit a path traversal flaw in Apache IoTDB to access or modify files outside the restricted directory, requiring an upgrade to secure the database.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2025-55017?
CVE-2025-55017 is a critical path traversal vulnerability in Apache IoTDB, published on 26 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache IoTDB.
This issue affects Apache IoTDB: from 2.0.0 before 2.0.6, from 1.0.0 before 1.3.6.
Users are recommended to upgrade to version 1.3.6 and 2.0.6, which fixes the issue.
Weakness: CWE-22
Which versions are affected by CVE-2025-55017?
How do I fix CVE-2025-55017?
No fix has been published for CVE-2025-55017 yet. Limit exposure of the affected software until one is available.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2025-55017 being exploited?
There is no known exploitation of CVE-2025-55017 in the wild and no public exploit code.
Sources
Also known as GHSA-xrvj-h9w2-3q69.