{"answers":{"affected":"3 open source packages ship an affected version, including tkeasygui and TkEasyGUI.","exploited":"There is no known exploitation of CVE-2025-55037 in the wild and no public exploit code.","fix":"Upgrade tkeasygui to 1.0.22 or later.","what":"CVE-2025-55037 is a critical command injection vulnerability in kujirahand TkEasyGUI, published on 5 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-55037 and fix it if it is affected.\n\nWhat it is: CVE-2025-55037 is a critical command injection vulnerability in kujirahand TkEasyGUI, published on 5 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-55037 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- tkeasygui (PyPI): affected all versions; fixed in 1.0.22\n- tkeasygui (PyPI): affected all versions; fixed in 1.0.22\n- TkEasyGUI (PyPI): affected all versions; fixed in 1.0.22\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-55037/ (Markdown: https://insights.sbomify.com/CVE-2025-55037/index.md)","id":"CVE-2025-55037","markdown":"https://insights.sbomify.com/CVE-2025-55037/index.md","name":"CVE-2025-55037","record":{"aliases":["GHSA-hfrj-3w3g-jv32","PYSEC-2026-552"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Python GUI library","requires_auth":"none","summary":"Remote attackers can execute arbitrary OS commands in TkEasyGUI if configured to use external message sources.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jpcert","cpe":[],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Improper neutralization of special elements used in an OS command ('OS Command Injection') issue exists in TkEasyGUI versions prior to v1.0.22. If this vulnerability is exploited, an arbitrary OS command may be executed by a remote unauthenticated attacker if the settings are configured to construct messages from external sources.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"TkEasyGUI Vulnerable to OS Command Injection","id":"CVE-2025-55037","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"AutomationDirect CLICK PLUS Missing Authorization","id":"CVE-2025-55038"},"packages":[{"ecosystem":"PyPI","fixed":["1.0.22"],"introduced":["0"],"last_affected":[],"package":"TkEasyGUI","purl":null,"source":"GHSA-hfrj-3w3g-jv32"},{"ecosystem":"PyPI","fixed":["1.0.22"],"introduced":["0"],"last_affected":[],"package":"tkeasygui","purl":"pkg:pypi/tkeasygui","source":"GHSA-hfrj-3w3g-jv32"},{"ecosystem":"PyPI","fixed":["1.0.22"],"introduced":["0"],"last_affected":[],"package":"tkeasygui","purl":"pkg:pypi/tkeasygui","source":"PYSEC-2026-552"}],"prev":{"headline":"BIG-IP SSL Orchestrator vulnerability","id":"CVE-2025-55036"},"products":["TkEasyGUI"],"published":"2025-09-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-09-05","vendors":["kujirahand"]},"summary":"Remote attackers can execute arbitrary OS commands in TkEasyGUI if configured to use external message sources.","url":"https://insights.sbomify.com/CVE-2025-55037/"}