# CVE-2025-55037: TkEasyGUI Vulnerable to OS Command Injection

> Remote attackers can execute arbitrary OS commands in TkEasyGUI if configured to use external message sources.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Sep 2025
- **Updated:** 5 Sep 2025
- **Also known as:** GHSA-hfrj-3w3g-jv32, PYSEC-2026-552

## What is CVE-2025-55037?

CVE-2025-55037 is a critical command injection vulnerability in kujirahand TkEasyGUI, published on 5 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper neutralization of special elements used in an OS command ('OS Command Injection') issue exists in TkEasyGUI versions prior to v1.0.22. If this vulnerability is exploited, an arbitrary OS command may be executed by a remote unauthenticated attacker if the settings are configured to construct messages from external sources.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2025-55037?

3 open source packages ship an affected version, including tkeasygui and TkEasyGUI.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tkeasygui` | PyPI | All versions | 1.0.22 |
| `tkeasygui` | PyPI | All versions | 1.0.22 |
| `TkEasyGUI` | PyPI | All versions | 1.0.22 |

## How do I fix CVE-2025-55037?

Upgrade tkeasygui to 1.0.22 or later.

## Is CVE-2025-55037 being exploited?

There is no known exploitation of CVE-2025-55037 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55037 and fix it if it is affected.

What it is: CVE-2025-55037 is a critical command injection vulnerability in kujirahand TkEasyGUI, published on 5 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-55037 in the wild and no public exploit code.

Affected packages and fixed versions:
- tkeasygui (PyPI): affected all versions; fixed in 1.0.22
- tkeasygui (PyPI): affected all versions; fixed in 1.0.22
- TkEasyGUI (PyPI): affected all versions; fixed in 1.0.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55037/ (Markdown: https://insights.sbomify.com/CVE-2025-55037/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55037
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55037
- OSV: https://osv.dev/vulnerability/CVE-2025-55037

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55037/
Summaries are generated and may contain mistakes; the official description above is the record.
