CVE-2025-55039 Apache Spark has Inadequate Encryption Strength
Man-in-the-middle attackers can modify encrypted RPC traffic in Apache Spark when using the default unauthenticated AES-CTR cipher, compromising workflow integrity.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-55039?
CVE-2025-55039 is a medium-severity vulnerability in Apache Spark, published on 15 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
This issue affects Apache Spark versions before 3.4.4, 3.5.2 and 4.0.0.
Apache Spark versions before 4.0.0, 3.5.2 and 3.4.4 use an insecure default network encryption cipher for RPC communication between nodes.
When spark.network.crypto.enabled is set to true (it is set to false by default), but spark.network.crypto.cipher is not explicitly configured, Spark defaults to AES in CTR mode (AES/CTR/NoPadding), which provides encryption without authentication.
This vulnerability allows a man-in-the-middle attacker to modify encrypted RPC traffic undetected by flipping bits in ciphertext, potentially compromising heartbeat messages or application data and affecting the integrity of Spark workflows.
To mitigate this issue, users should either configure spark.network.crypto.cipher to AES/GCM/NoPadding to enable authenticated encryption or
enable SSL encryption by setting spark.ssl.enabled to true, which provides stronger transport security.
Which versions are affected by CVE-2025-55039?
13 open source packages ship an affected version, including org.apache.spark:spark-network-common_2.12, org.apache.spark:spark-network-common_2.13 and pyspark. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.spark:spark-network-common_2.12 Maven | All versions | 3.4.4 |
org.apache.spark:spark-network-common_2.12 Maven | All versions | 3.4.4 |
org.apache.spark:spark-network-common_2.12 Maven | From 3.5.0 | 3.5.2 |
org.apache.spark:spark-network-common_2.12 Maven | From 3.5.0 | 3.5.2 |
org.apache.spark:spark-network-common_2.13 Maven | All versions | 3.4.4 |
org.apache.spark:spark-network-common_2.13 Maven | All versions | 3.4.4 |
7 more packages
org.apache.spark:spark-network-common_2.13 Maven | From 3.5.0 | 3.5.2 |
org.apache.spark:spark-network-common_2.13 Maven | From 3.5.0 | 3.5.2 |
pyspark PyPI | All versions | 3.4.4, 3.5.2 |
pyspark PyPI | All versions | 3.4.4 |
pyspark PyPI | All versions | 3.4.4 |
pyspark PyPI | From 3.5.0 | 3.5.2 |
pyspark PyPI | From 3.5.0 | 3.5.2 |
Products include Apache Spark.
How do I fix CVE-2025-55039?
Upgrade org.apache.spark:spark-network-common_2.12 to a fixed version for your release line: 3.4.4 or 3.5.2.
Is CVE-2025-55039 being exploited?
There is no known exploitation of CVE-2025-55039 in the wild and no public exploit code.
Other vulnerabilities in Apache Spark
Sources
Also known as GHSA-6p6v-m64v-jx8q, PYSEC-2025-184.