CVE-2025-55073 MS Teams plugin OAuth allows editing arbitrary posts
Attackers can edit arbitrary posts in Mattermost by exploiting insufficient validation in the MS Teams plugin OAuth flow.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-55073?
CVE-2025-55073 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 14 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 10.11.x <= 10.11.3, 10.5.x <= 10.5.11, 10.12.x <= 10.12.0 fail to validate the relationship between the post being updated and the MSTeams plugin OAuth flow which allows an attacker to edit arbitrary posts via a crafted MSTeams plugin OAuth redirect URL.
Weakness: CWE-306
Which versions are affected by CVE-2025-55073?
12 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.4 |
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.4 |
github.com/mattermost/mattermost-server Go | From 10.12.0 | 10.12.1 |
github.com/mattermost/mattermost-server Go | From 10.12.0 | 10.12.1 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.12 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.12 |
6 more packages
github.com/mattermost/mattermost-server Go | From 10.5.0+incompatible | 10.5.12+incompatible, 10.11.4+incompatible, 10.12.1+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250929212932-a41db04d2746 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250929212932-a41db04d2746 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250929212932-a41db04d2746 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-55073?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.4, 10.12.1, 10.5.12 or 10.5.12+incompatible.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-55073 being exploited?
There is no known exploitation of CVE-2025-55073 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-ff85-qw3h-g9vp, GO-2025-4129.