CVE-2025-55074 Channel member objects leak read status
Attackers can determine when users read channels by exploiting missing access controls in the Agents plugin, leaking sensitive user activity data.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-55074?
CVE-2025-55074 is a low-severity vulnerability in Mattermost Mattermost Server, published on 18 Nov 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Mattermost versions 10.11.x <= 10.11.3, 10.5.x <= 10.5.11 fail to enforce access permissions on the Agents plugin which allows other users to determine when users had read channels via channel member objects
Weakness: CWE-1426
Which versions are affected by CVE-2025-55074?
10 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.4 |
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.4 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.12 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.12 |
github.com/mattermost/mattermost-server Go | From 10.5.0+incompatible | 10.5.12+incompatible, 10.11.4+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
4 more packages
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250905150616-ba86dfc5876b6 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250905150616-ba86dfc5876b6 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-55074?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.4, 10.5.12, 10.5.12+incompatible or 10.11.4+incompatible.
Is CVE-2025-55074 being exploited?
There is no known exploitation of CVE-2025-55074 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-9hh7-6558-qfp2, GO-2025-4133.