# CVE-2025-55074: Channel member objects leak read status

> Attackers can determine when users read channels by exploiting missing access controls in the Agents plugin, leaking sensitive user activity data.

- **Severity:** Low 3.0 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Nov 2025
- **Updated:** 18 Nov 2025
- **Also known as:** GHSA-9hh7-6558-qfp2, GO-2025-4133

## What is CVE-2025-55074?

CVE-2025-55074 is a low-severity vulnerability in Mattermost Mattermost Server, published on 18 Nov 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Mattermost versions 10.11.x <= 10.11.3, 10.5.x <= 10.5.11 fail to enforce access permissions on the Agents plugin which allows other users to determine when users had read channels via channel member objects

Weakness: CWE-1426 (Improper Validation of Generative AI Output)

## Which versions are affected by CVE-2025-55074?

10 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | 10.11.4 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | 10.11.4 |
| `github.com/mattermost/mattermost-server` | Go | From 10.5.0 | 10.5.12 |
| `github.com/mattermost/mattermost-server` | Go | From 10.5.0 | 10.5.12 |
| `github.com/mattermost/mattermost-server` | Go | From 10.5.0+incompatible | 10.5.12+incompatible, 10.11.4+incompatible |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250905150616-ba86dfc5876b6 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250905150616-ba86dfc5876b6 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2025-55074?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.4, 10.5.12, 10.5.12+incompatible or 10.11.4+incompatible.

## Is CVE-2025-55074 being exploited?

There is no known exploitation of CVE-2025-55074 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55074 and fix it if it is affected.

What it is: CVE-2025-55074 is a low-severity vulnerability in Mattermost Mattermost Server, published on 18 Nov 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-55074 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; fixed in 10.11.4
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; fixed in 10.11.4
- github.com/mattermost/mattermost-server (Go): affected from 10.5.0; fixed in 10.5.12
- github.com/mattermost/mattermost-server (Go): affected from 10.5.0; fixed in 10.5.12
- github.com/mattermost/mattermost-server (Go): affected from 10.5.0+incompatible; fixed in 10.5.12+incompatible, 10.11.4+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250905150616-ba86dfc5876b6
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250905150616-ba86dfc5876b6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55074/ (Markdown: https://insights.sbomify.com/CVE-2025-55074/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55074
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55074
- OSV: https://osv.dev/vulnerability/CVE-2025-55074

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55074/
Summaries are generated and may contain mistakes; the official description above is the record.
