{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-55158 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2025-55158 is a medium-severity use after free vulnerability in Vim Vim, published on 11 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-55158 and fix it if it is affected.\n\nWhat it is: CVE-2025-55158 is a medium-severity use after free vulnerability in Vim Vim, published on 11 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-55158 in the wild and no public exploit code.\n\nAffected product: Vim Vim. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-55158/ (Markdown: https://insights.sbomify.com/CVE-2025-55158/index.md)","id":"CVE-2025-55158","markdown":"https://insights.sbomify.com/CVE-2025-55158/index.md","name":"CVE-2025-55158","record":{"aliases":["BELL-CVE-2025-55158","GHSA-5fg8-wvx3-583x"],"analysis":{"component_type":"desktop_application","fix_type":"patch","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Vim text editor","requires_auth":"none","summary":"A double-free vulnerability in Vim allows attackers to execute arbitrary code or cause a crash by tricking users into opening a malicious Vim script.","user_interaction":"required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"vim","vendor":"vim"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-415","name":"Double Free"}],"description":"Vim is an open source, command line text editor. In versions from 9.1.1231 to before 9.1.1406, when processing nested tuples during Vim9 script import operations, an error during evaluation can trigger a double-free in Vim’s internal typed value (typval_T) management. Specifically, the clear_tv() function may attempt to free memory that has already been deallocated, due to improper lifetime handling in the handle_import / ex_import code paths. The vulnerability can only be triggered if a user explicitly opens and executes a specially crafted Vim script. This issue has been patched in version 9.1.1406.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Vim double-free vulnerability during Vim9 script import operations","id":"CVE-2025-55158","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"vim:vim","products":["vim:vim"],"type":"use_after_free","year":"2025"},"n_packages":0,"n_references":3,"next":{"headline":"slab allows out-of-bounds access in `get_disjoint_mut` due to incorrect bounds check","id":"CVE-2025-55159"},"packages":[],"prev":{"headline":"Vim heap use-after-free vulnerability when processing recursive tuple data types","id":"CVE-2025-55157"},"products":["vim"],"published":"2025-08-11","related":[{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2020-20703","kev_date_added":null,"published":"2023-06-20"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2017-6349","kev_date_added":null,"published":"2017-02-27"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2017-6350","kev_date_added":null,"published":"2017-02-27"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2017-5953","kev_date_added":null,"published":"2017-02-10"},{"cvss_score":9.3,"headline":"Command injection in n/a","id":"CVE-2008-3075","kev_date_added":null,"published":"2009-02-21"},{"cvss_score":9.3,"headline":"Command injection in n/a","id":"CVE-2008-3076","kev_date_added":null,"published":"2009-02-21"},{"cvss_score":9.3,"headline":"Command injection in n/a","id":"CVE-2008-6235","kev_date_added":null,"published":"2009-02-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-08-12","vendors":["vim"]},"summary":"A double-free vulnerability in Vim allows attackers to execute arbitrary code or cause a crash by tricking users into opening a malicious Vim script.","url":"https://insights.sbomify.com/CVE-2025-55158/"}