CVE-2025-55162 Envoy: oAuth2 Filter Signout route will not clear cookies because of missing "secure;" flag
Envoy OAuth2 filter fails to clear secure cookies on logout, allowing session hijacking on shared computers if specific cookie prefixes are used.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-55162?
CVE-2025-55162 is a medium-severity vulnerability in Envoyproxy Envoy, published on 3 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Envoy is an open source L7 proxy and communication bus designed for large modern service oriented architectures. In versions below 1.32.10 and 1.33.0 through 1.33.6, 1.34.0 through 1.34.4 and 1.35.0, insufficient Session Expiration in the Envoy OAuth2 filter leads to failed logout operations. When configured with __Secure- or __Host- prefixed cookie names, the filter fails to append the required Secure attribute to the Set-Cookie header during deletion. Modern browsers ignore this invalid request, causing the session cookie to persist. This allows a user to remain logged in after they believe they have logged out, creating a session hijacking risk on shared computers. The current implementation iterates through the configured cookie names to generate deletion headers but does not check for these prefixes. This failure to properly construct the deletion header means the user's session cookies are never removed by the browser, leaving the session active and allowing the next user of the same browser to gain unauthorized access to the original user's account and data. This is fixed in versions 1.32.10, 1.33.7, 1.34.5 and 1.35.1.
Weakness: CWE-613
Which versions are affected by CVE-2025-55162?
1 open source package ship an affected version, including envoy. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
envoy Bitnami | All versions | 1.32.10, 1.33.7, 1.34.5, 1.35.1 |
Products include Envoyproxy Envoy.
How do I fix CVE-2025-55162?
Upgrade envoy to a fixed version for your release line: 1.32.10, 1.33.7, 1.34.5 or 1.35.1.
Is CVE-2025-55162 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55162 exists.
Other vulnerabilities in Envoyproxy Envoy
Sources
Also known as BIT-envoy-2025-55162, GHSA-95j4-hw7f-v2rh.