# CVE-2025-55162: Envoy: oAuth2 Filter Signout route will not clear cookies because of missing "secure;" flag

> Envoy OAuth2 filter fails to clear secure cookies on logout, allowing session hijacking on shared computers if specific cookie prefixes are used.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Sep 2025
- **Updated:** 4 Sep 2025
- **Also known as:** BIT-envoy-2025-55162, GHSA-95j4-hw7f-v2rh

## What is CVE-2025-55162?

CVE-2025-55162 is a medium-severity vulnerability in Envoyproxy Envoy, published on 3 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Envoy is an open source L7 proxy and communication bus designed for large modern service oriented architectures. In versions below 1.32.10 and 1.33.0 through 1.33.6, 1.34.0 through 1.34.4 and 1.35.0, insufficient Session Expiration in the Envoy OAuth2 filter leads to failed logout operations. When configured with __Secure- or __Host- prefixed cookie names, the filter fails to append the required Secure attribute to the Set-Cookie header during deletion. Modern browsers ignore this invalid request, causing the session cookie to persist. This allows a user to remain logged in after they believe they have logged out, creating a session hijacking risk on shared computers. The current implementation iterates through the configured cookie names to generate deletion headers but does not check for these prefixes. This failure to properly construct the deletion header means the user's session cookies are never removed by the browser, leaving the session active and allowing the next user of the same browser to gain unauthorized access to the original user's account and data. This is fixed in versions 1.32.10, 1.33.7, 1.34.5 and 1.35.1.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2025-55162?

1 open source package ship an affected version, including envoy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `envoy` | Bitnami | All versions | 1.32.10, 1.33.7, 1.34.5, 1.35.1 |

Products: Envoyproxy Envoy.

## How do I fix CVE-2025-55162?

Upgrade envoy to a fixed version for your release line: 1.32.10, 1.33.7, 1.34.5 or 1.35.1.

## Is CVE-2025-55162 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55162 exists.

## Other vulnerabilities in Envoyproxy Envoy

- [CVE-2022-29226](https://insights.sbomify.com/CVE-2022-29226/): Trivial authentication bypass in Envoy (critical 10.0)
- [CVE-2019-18801](https://insights.sbomify.com/CVE-2019-18801/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-18802](https://insights.sbomify.com/CVE-2019-18802/): Security feature bypass in n/a (critical 9.8)
- [CVE-2020-35470](https://insights.sbomify.com/CVE-2020-35470/): Information disclosure in n/a (high 8.8)
- [CVE-2024-23324](https://insights.sbomify.com/CVE-2024-23324/): Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55162 and fix it if it is affected.

What it is: CVE-2025-55162 is a medium-severity vulnerability in Envoyproxy Envoy, published on 3 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55162 exists.

Affected packages and fixed versions:
- envoy (Bitnami): affected all versions; fixed in 1.32.10, 1.33.7, 1.34.5, 1.35.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55162/ (Markdown: https://insights.sbomify.com/CVE-2025-55162/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55162
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55162
- OSV: https://osv.dev/vulnerability/CVE-2025-55162

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55162/
Summaries are generated and may contain mistakes; the official description above is the record.
