CVE-2025-55163 Netty MadeYouReset HTTP/2 DDoS Vulnerability
Attackers can cause resource exhaustion and denial of service in applications using Netty by sending malformed HTTP/2 control frames.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-55163?
CVE-2025-55163 is a high-severity denial of service vulnerability in Netty Netty, published on 13 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.124.Final and 4.2.4.Final, Netty is vulnerable to MadeYouReset DDoS. This is a logical vulnerability in the HTTP/2 protocol, that uses malformed HTTP/2 control frames in order to break the max concurrent streams limit - which results in resource exhaustion and distributed denial of service. This issue has been patched in versions 4.1.124.Final and 4.2.4.Final.
Weakness: CWE-770
Which versions are affected by CVE-2025-55163?
6 open source packages ship an affected version, including io.netty:netty-codec-http2 and io.grpc:grpc-netty-shaded. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
io.netty:netty-codec-http2 Maven | All versions | 4.1.124.Final |
io.netty:netty-codec-http2 Maven | All versions | 4.1.124.Final |
io.netty:netty-codec-http2 Maven | From 4.2.0.Alpha1 | 4.2.4.Final |
io.netty:netty-codec-http2 Maven | From 4.2.0.Alpha1 | 4.2.4.Final |
io.grpc:grpc-netty-shaded Maven | All versions | 1.75.0 |
io.grpc:grpc-netty-shaded Maven | All versions | 1.75.0 |
Linux distribution packages (2)
netty SUSE:Manager Server LTS 4.3 | All versions | 4.1.44.Final-150400.3.9.1 |
netty openSUSE:Tumbleweed | All versions | 4.1.124-1.1 |
Products include Netty Netty.
How do I fix CVE-2025-55163?
Upgrade io.netty:netty-codec-http2 to a fixed version for your release line: 4.1.124.Final or 4.2.4.Final.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-55163 being exploited?
There is no known exploitation of CVE-2025-55163 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Netty Netty
- CVE-2026-75595 Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext
- CVE-2026-75596 Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing
- CVE-2026-59901 Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang
- CVE-2026-55851 Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion
- CVE-2026-56745 Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion
Sources
Also known as CLEANSTART-2026-IO60317, CLEANSTART-2026-MT95213, CLEANSTART-2026-QY34934, CLSA-2026-1777250325, CLSA-2026-1793141030, DEBIAN-CVE-2025-55163 and 35 more.