# CVE-2025-55163: Netty MadeYouReset HTTP/2 DDoS Vulnerability

> Attackers can cause resource exhaustion and denial of service in applications using Netty by sending malformed HTTP/2 control frames.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2025
- **Updated:** 4 Nov 2025
- **Also known as:** CLEANSTART-2026-IO60317, CLEANSTART-2026-MT95213, CLEANSTART-2026-QY34934, CLSA-2026-1777250325, CLSA-2026-1793141030, DEBIAN-CVE-2025-55163, ECHO-e753-218c-9042, GHSA-prj3-ccx8-p6x4, MINI-2x25-w2gp-px56, MINI-33f6-4vxh-4hgv, MINI-36jv-pmh5-j7h7, MINI-52cf-fjjc-536x, MINI-6jwp-2jg3-fm7v, MINI-8vjj-ph5r-97rq, MINI-9339-q2q8-f457, MINI-939j-pv28-6gpx, MINI-9m9p-2f6j-327f, MINI-f4gq-m2w5-22gw, MINI-gfpf-9qq7-4785, MINI-gm83-vx29-9cw4, MINI-m324-8xc7-chx3, MINI-m729-p95m-68c8, MINI-m8vc-j4wj-2fpv, MINI-mcwf-vrf9-5763, MINI-mhx9-29p5-p4m4, MINI-p8xr-hv33-wwmp, MINI-ph9v-jvq7-4wf6, MINI-phrw-gmm4-8x2c, MINI-q479-9752-97p7, MINI-rg98-mr64-f8f6, MINI-vjm9-vcpp-hhjr, MINI-vxjm-55gm-cm9q, MINI-w2g2-qxrm-pg45, MINI-w4qx-gc38-8jv2, MINI-w5v7-xhrf-gccc, MINI-x2mh-7528-65r6, MINI-xf92-2q3q-28qp, ROOT-APP-MAVEN-CVE-2025-55163, SUSE-SU-2025:03021-1, UBUNTU-CVE-2025-55163, openSUSE-SU-2025:15483-1

## What is CVE-2025-55163?

CVE-2025-55163 is a high-severity denial of service vulnerability in Netty Netty, published on 13 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.124.Final and 4.2.4.Final, Netty is vulnerable to MadeYouReset DDoS. This is a logical vulnerability in the HTTP/2 protocol, that uses malformed HTTP/2 control frames in order to break the max concurrent streams limit - which results in resource exhaustion and distributed denial of service. This issue has been patched in versions 4.1.124.Final and 4.2.4.Final.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-55163?

6 open source packages ship an affected version, including io.netty:netty-codec-http2 and io.grpc:grpc-netty-shaded. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty-codec-http2` | Maven | All versions | 4.1.124.Final |
| `io.netty:netty-codec-http2` | Maven | All versions | 4.1.124.Final |
| `io.netty:netty-codec-http2` | Maven | From 4.2.0.Alpha1 | 4.2.4.Final |
| `io.netty:netty-codec-http2` | Maven | From 4.2.0.Alpha1 | 4.2.4.Final |
| `io.grpc:grpc-netty-shaded` | Maven | All versions | 1.75.0 |
| `io.grpc:grpc-netty-shaded` | Maven | All versions | 1.75.0 |
| `netty` | SUSE:Manager Server LTS 4.3 | All versions | 4.1.44.Final-150400.3.9.1 |
| `netty` | openSUSE:Tumbleweed | All versions | 4.1.124-1.1 |

Products: Netty Netty.

## How do I fix CVE-2025-55163?

Upgrade io.netty:netty-codec-http2 to a fixed version for your release line: 4.1.124.Final or 4.2.4.Final.

## Is CVE-2025-55163 being exploited?

There is no known exploitation of CVE-2025-55163 in the wild and no public exploit code.

Public exploit code:

- CVE-2025-55163 / CVE-2026-56819: offline checker for the 7 netty-codec-http2 CVEs. Tells you which ones you are exposed to, and the one version that fixes all seven (4.1.136.Final / 4.2.16.Final) - written on none of the advisories. Does not scan pom.xml on purpose: WebFlux pulls it in transitively. (github_poc): https://github.com/xiaoqiMikko/netty-http2-check

## Other vulnerabilities in Netty Netty

- [CVE-2026-75595](https://insights.sbomify.com/CVE-2026-75595/): Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext (critical 9.1)
- [CVE-2026-75596](https://insights.sbomify.com/CVE-2026-75596/): Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing (high 8.7)
- [CVE-2026-59901](https://insights.sbomify.com/CVE-2026-59901/): Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang (high 8.7)
- [CVE-2026-55851](https://insights.sbomify.com/CVE-2026-55851/): Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion (high 8.7)
- [CVE-2026-56745](https://insights.sbomify.com/CVE-2026-56745/): Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55163 and fix it if it is affected.

What it is: CVE-2025-55163 is a high-severity denial of service vulnerability in Netty Netty, published on 13 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-55163 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.netty:netty-codec-http2 (Maven): affected all versions; fixed in 4.1.124.Final
- io.netty:netty-codec-http2 (Maven): affected all versions; fixed in 4.1.124.Final
- io.netty:netty-codec-http2 (Maven): affected from 4.2.0.Alpha1; fixed in 4.2.4.Final
- io.netty:netty-codec-http2 (Maven): affected from 4.2.0.Alpha1; fixed in 4.2.4.Final
- io.grpc:grpc-netty-shaded (Maven): affected all versions; fixed in 1.75.0
- io.grpc:grpc-netty-shaded (Maven): affected all versions; fixed in 1.75.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55163/ (Markdown: https://insights.sbomify.com/CVE-2025-55163/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55163
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55163
- OSV: https://osv.dev/vulnerability/CVE-2025-55163

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55163/
Summaries are generated and may contain mistakes; the official description above is the record.
