{"answers":{"affected":"2 open source packages ship an affected version, including content-security-policy-parser.","exploited":"There is no known exploitation of CVE-2025-55164 in the wild and no public exploit code.","fix":"Upgrade content-security-policy-parser to 0.6.0 or later.","what":"CVE-2025-55164 is a high-severity code injection vulnerability in helmetjs content-security-policy-parser, published on 12 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-55164 and fix it if it is affected.\n\nWhat it is: CVE-2025-55164 is a high-severity code injection vulnerability in helmetjs content-security-policy-parser, published on 12 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-55164 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- content-security-policy-parser (npm): affected all versions; fixed in 0.6.0\n- content-security-policy-parser (npm): affected all versions; fixed in 0.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-55164/ (Markdown: https://insights.sbomify.com/CVE-2025-55164/index.md)","id":"CVE-2025-55164","markdown":"https://insights.sbomify.com/CVE-2025-55164/index.md","name":"CVE-2025-55164","record":{"aliases":["GHSA-w2cq-g8g3-gm83"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js CSP parser","requires_auth":"none","summary":"Prototype pollution in the content-security-policy-parser library allows attackers to override Object prototypes, potentially leading to remote code execution.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-1321","name":"Improperly Controlled Modification of Object Prototype Attributes"}],"description":"content-security-policy-parser parses content security policy directives. A prototype pollution vulnerability exists in versions 0.5.0 and earlier, wherein if a policy name is called __proto__, one can override the Object prototype. This issue has been patched in version 0.6.0. A workaround involves disabling prototype method in NodeJS, neutralizing all possible prototype pollution attacks. Provide either --disable-proto=delete (recommended) or --disable-proto=throw as an argument to node to enable this feature.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"content-security-policy-parser Prototype Pollution Vulnerability May Lead to RCE","id":"CVE-2025-55164","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"Autocaliweb Exposure of Sensitive Information to an Unauthorized Actor in `config_sql.py`","id":"CVE-2025-55165"},"packages":[{"ecosystem":"npm","fixed":["0.6.0"],"introduced":["0"],"last_affected":[],"package":"content-security-policy-parser","purl":null,"source":"GHSA-w2cq-g8g3-gm83"},{"ecosystem":"npm","fixed":["0.6.0"],"introduced":["0"],"last_affected":[],"package":"content-security-policy-parser","purl":"pkg:npm/content-security-policy-parser","source":"GHSA-w2cq-g8g3-gm83"}],"prev":{"headline":"Netty MadeYouReset HTTP/2 DDoS Vulnerability","id":"CVE-2025-55163"},"products":["content-security-policy-parser"],"published":"2025-08-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-08-20","vendors":["helmetjs"]},"summary":"Prototype pollution in the content-security-policy-parser library allows attackers to override Object prototypes, potentially leading to remote code execution.","url":"https://insights.sbomify.com/CVE-2025-55164/"}