# CVE-2025-55164: content-security-policy-parser Prototype Pollution Vulnerability May Lead to RCE

> Prototype pollution in the content-security-policy-parser library allows attackers to override Object prototypes, potentially leading to remote code execution.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Aug 2025
- **Updated:** 20 Aug 2025
- **Also known as:** GHSA-w2cq-g8g3-gm83

## What is CVE-2025-55164?

CVE-2025-55164 is a high-severity code injection vulnerability in helmetjs content-security-policy-parser, published on 12 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

content-security-policy-parser parses content security policy directives. A prototype pollution vulnerability exists in versions 0.5.0 and earlier, wherein if a policy name is called __proto__, one can override the Object prototype. This issue has been patched in version 0.6.0. A workaround involves disabling prototype method in NodeJS, neutralizing all possible prototype pollution attacks. Provide either --disable-proto=delete (recommended) or --disable-proto=throw as an argument to node to enable this feature.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2025-55164?

2 open source packages ship an affected version, including content-security-policy-parser.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `content-security-policy-parser` | npm | All versions | 0.6.0 |
| `content-security-policy-parser` | npm | All versions | 0.6.0 |

## How do I fix CVE-2025-55164?

Upgrade content-security-policy-parser to 0.6.0 or later.

## Is CVE-2025-55164 being exploited?

There is no known exploitation of CVE-2025-55164 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55164 and fix it if it is affected.

What it is: CVE-2025-55164 is a high-severity code injection vulnerability in helmetjs content-security-policy-parser, published on 12 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-55164 in the wild and no public exploit code.

Affected packages and fixed versions:
- content-security-policy-parser (npm): affected all versions; fixed in 0.6.0
- content-security-policy-parser (npm): affected all versions; fixed in 0.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55164/ (Markdown: https://insights.sbomify.com/CVE-2025-55164/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55164
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55164
- OSV: https://osv.dev/vulnerability/CVE-2025-55164

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55164/
Summaries are generated and may contain mistakes; the official description above is the record.
