# CVE-2025-55165: Autocaliweb Exposure of Sensitive Information to an Unauthorized Actor in `config_sql.py`

> Autocaliweb debug packs leak sensitive API keys due to inadequate filtering, allowing unauthorized access to private credentials.

- **Severity:** High 8.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 12 Aug 2025
- **Updated:** 13 Aug 2025
- **Also known as:** GHSA-44vp-wgh9-9535

## What is CVE-2025-55165?

CVE-2025-55165 is a high-severity vulnerability in gelbphoenix autocaliweb, published on 12 Aug 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Autocaliweb is a web app that offers an interface for browsing, reading, and downloading eBooks using a valid Calibre database. Prior to version 0.8.3, the debug pack generated by Autocaliweb can expose sensitive configuration data, including API keys. This occurs because the to_dict() method, used to serialize configuration for the debug pack, doesn't adequately filter out sensitive fields such as API tokens. Users, unaware of the full contents, might share these debug packs, inadvertently leaking their private API keys. This issue has been patched in version 0.8.3.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-55165?


## How do I fix CVE-2025-55165?

No fix has been published for CVE-2025-55165 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-55165 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55165 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55165 and fix it if it is affected.

What it is: CVE-2025-55165 is a high-severity vulnerability in gelbphoenix autocaliweb, published on 12 Aug 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55165 exists.

Affected product: gelbphoenix autocaliweb. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55165/ (Markdown: https://insights.sbomify.com/CVE-2025-55165/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55165
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55165
- OSV: https://osv.dev/vulnerability/CVE-2025-55165

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55165/
Summaries are generated and may contain mistakes; the official description above is the record.
