# CVE-2025-55166: svg-sanitizer By-Passing Attribute Sanitization

> Attackers can bypass attribute sanitization in the PHP SVG sanitizer to inject malicious scripts or links, leading to XSS or open redirects.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Aug 2025
- **Updated:** 12 Aug 2025
- **Also known as:** CLSA-2026-1787820940, GHSA-22wq-q86m-83fh

## What is CVE-2025-55166?

CVE-2025-55166 is a medium-severity cross-site scripting vulnerability in darylldoyle svg-sanitizer, published on 12 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

savg-sanitizer is a PHP SVG/XML sanitizer. Prior to version 0.22.0, the sanitization logic in the cleanXlinkHrefs method only searches for lower-case attribute name, which allows to by-pass the isHrefSafeValue check. As a result this allows cross-site scripting or linking to external domains. This issue has been patched in version 0.22.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2025-55166?

2 open source packages ship an affected version, including enshrined/svg-sanitize.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `enshrined/svg-sanitize` | Packagist | All versions | 0.22.0 |
| `enshrined/svg-sanitize` | Packagist | All versions | 0.22.0 |

## How do I fix CVE-2025-55166?

Upgrade enshrined/svg-sanitize to 0.22.0 or later.

## Is CVE-2025-55166 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55166 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55166 and fix it if it is affected.

What it is: CVE-2025-55166 is a medium-severity cross-site scripting vulnerability in darylldoyle svg-sanitizer, published on 12 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55166 exists.

Affected packages and fixed versions:
- enshrined/svg-sanitize (Packagist): affected all versions; fixed in 0.22.0
- enshrined/svg-sanitize (Packagist): affected all versions; fixed in 0.22.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55166/ (Markdown: https://insights.sbomify.com/CVE-2025-55166/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55166
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55166
- OSV: https://osv.dev/vulnerability/CVE-2025-55166

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55166/
Summaries are generated and may contain mistakes; the official description above is the record.
