CVE-2025-55173 Next.js Content Injection Vulnerability for Image Optimization

Medium 4.3 Published Updated

Attackers can inject malicious content via image optimization, enabling phishing or file delivery in specific Next.js configurations.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-55173?

CVE-2025-55173 is a medium-severity vulnerability in Vercel Next.js, published on 29 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Next.js is a React framework for building full-stack web applications. In versions before 14.2.31 and from 15.0.0 to before 15.4.5, Next.js Image Optimization is vulnerable to content injection. The issue allowed attacker-controlled external image sources to trigger file downloads with arbitrary content and filenames under specific configurations. This behavior could be abused for phishing or malicious file delivery. This vulnerability has been fixed in Next.js versions 14.2.31 and 15.4.5.

Weakness: CWE-20

Which versions are affected by CVE-2025-55173?

4 open source packages ship an affected version, including next. It affects 1 product.

PackageAffectedFixed in
next npmFrom 0.9.914.2.31
next npmFrom 0.9.914.2.31
next npmFrom 15.0.015.4.5
next npmFrom 15.0.015.4.5

Products include Vercel Next.js.

How do I fix CVE-2025-55173?

Upgrade next to a fixed version for your release line: 14.2.31 or 15.4.5.

Is CVE-2025-55173 being exploited?

There is no known exploitation of CVE-2025-55173 in the wild and no public exploit code.

All Vercel Next.js vulnerabilities

Sources

Also known as GHSA-xv57-4mr9-wg8v, MINI-mwh6-gcfm-6cgg, ROOT-APP-NPM-CVE-2025-55173.

Is CVE-2025-55173 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free