# CVE-2025-55191: Repository Credentials Race Condition Crashes Argo CD Server

> Attackers with repository permissions can trigger a race condition to crash the Argo CD server, causing denial of service.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Sep 2025
- **Updated:** 6 Oct 2025
- **Also known as:** BIT-argo-cd-2025-55191, CLEANSTART-2026-WW74873, GHSA-g88p-r42r-ppp9, GO-2025-3994, MINI-79fx-pg7f-237j, MINI-7fmc-mxfv-p4v5, MINI-7jh6-3h2x-8j5h, MINI-98g5-hxqp-chjh, MINI-gfhg-6rcm-x9f7, MINI-h5px-3m78-hcjg, MINI-m59g-93p5-q753, MINI-qg84-3p5j-9gh2, MINI-r2r5-h88x-q8xh, MINI-r4rj-3rmj-c7g8

## What is CVE-2025-55191?

CVE-2025-55191 is a medium-severity vulnerability in Argoproj Argo Cd, published on 30 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Argo CD is a declarative, GitOps continuous delivery tool for Kubernetes. Versions between 2.1.0 and 2.14.19, 3.2.0-rc1, 3.1.0-rc1 through 3.1.7, and 3.0.0-rc1 through 3.0.18 contain a race condition in the repository credentials handler that can cause the Argo CD server to panic and crash when concurrent operations are performed on the same repository URL. The vulnerability is located in numerous repository related handlers in the util/db/repository_secrets.go file. A valid API token with repositories resource permissions (create, update, or delete actions) is required to trigger the race condition. This vulnerability causes the entire Argo CD server to crash and become unavailable. Attackers can repeatedly and continuously trigger the race condition to maintain a denial-of-service state, disrupting all GitOps operations. This issue is fixed in versions 2.14.20, 3.2.0-rc2, 3.1.8 and 3.0.19.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2025-55191?

12 open source packages ship an affected version, including github.com/argoproj/argo-cd/v3, argo-cd and github.com/argoproj/argo-cd. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/argoproj/argo-cd/v3` | Go | From 3.0.0-rc1 | 3.0.19, 3.1.8, 3.2.0-rc2 |
| `github.com/argoproj/argo-cd/v3` | Go | From 3.0.0-rc1 | 3.0.19 |
| `github.com/argoproj/argo-cd/v3` | Go | From 3.0.0-rc1 | 3.0.19 |
| `github.com/argoproj/argo-cd/v3` | Go | From 3.1.0-rc1 | 3.1.8 |
| `github.com/argoproj/argo-cd/v3` | Go | From 3.1.0-rc1 | 3.1.8 |
| `github.com/argoproj/argo-cd/v3` | Go | From 3.2.0-rc1 | 3.2.0-rc2 |
| `github.com/argoproj/argo-cd/v3` | Go | From 3.2.0-rc1 | 3.2.0-rc2 |
| `argo-cd` | Bitnami | From 2.1.0 | 2.14.20, 3.0.19, 3.1.8 |
| `github.com/argoproj/argo-cd` | Go | All versions | None |
| `github.com/argoproj/argo-cd/v2` | Go | From 2.1.0 | 2.14.20 |
| `github.com/argoproj/argo-cd/v2` | Go | From 2.1.0 | 2.14.20 |
| `github.com/argoproj/argo-cd/v2` | Go | From 2.1.0 | 2.14.20 |

Products: Argoproj Argo Cd.

## How do I fix CVE-2025-55191?

Upgrade github.com/argoproj/argo-cd/v3 to a fixed version for your release line: 3.0.19, 3.1.8 or 3.2.0-rc2.

## Is CVE-2025-55191 being exploited?

There is no known exploitation of CVE-2025-55191 in the wild and no public exploit code.

## Other vulnerabilities in Argoproj Argo Cd

- [CVE-2025-55190](https://insights.sbomify.com/CVE-2025-55190/): Argo CD: Project API Token Exposes Repository Credentials (critical 10.0)
- [CVE-2022-29165](https://insights.sbomify.com/CVE-2022-29165/): Argo CD will blindly trust JWT claims if anonymous access is enabled (critical 10.0)
- [CVE-2023-40029](https://insights.sbomify.com/CVE-2023-40029/): Cluster secret might leak in cluster details page in Argo CD (critical 9.9)
- [CVE-2022-24768](https://insights.sbomify.com/CVE-2022-24768/): Improper access control allows admin privilege escalation in Argo CD (critical 9.9)
- [CVE-2024-21652](https://insights.sbomify.com/CVE-2024-21652/): Argo CD vulnerable to Bypassing of Brute Force Protection via Application Crash and In-Memory Data Loss (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55191 and fix it if it is affected.

What it is: CVE-2025-55191 is a medium-severity vulnerability in Argoproj Argo Cd, published on 30 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-55191 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/argoproj/argo-cd/v3 (Go): affected from 3.0.0-rc1; fixed in 3.0.19, 3.1.8, 3.2.0-rc2
- github.com/argoproj/argo-cd/v3 (Go): affected from 3.0.0-rc1; fixed in 3.0.19
- github.com/argoproj/argo-cd/v3 (Go): affected from 3.0.0-rc1; fixed in 3.0.19
- github.com/argoproj/argo-cd/v3 (Go): affected from 3.1.0-rc1; fixed in 3.1.8
- github.com/argoproj/argo-cd/v3 (Go): affected from 3.1.0-rc1; fixed in 3.1.8
- github.com/argoproj/argo-cd/v3 (Go): affected from 3.2.0-rc1; fixed in 3.2.0-rc2
- github.com/argoproj/argo-cd/v3 (Go): affected from 3.2.0-rc1; fixed in 3.2.0-rc2
- argo-cd (Bitnami): affected from 2.1.0; fixed in 2.14.20, 3.0.19, 3.1.8
- github.com/argoproj/argo-cd (Go): affected all versions; no fix listed
- github.com/argoproj/argo-cd/v2 (Go): affected from 2.1.0; fixed in 2.14.20
- github.com/argoproj/argo-cd/v2 (Go): affected from 2.1.0; fixed in 2.14.20
- github.com/argoproj/argo-cd/v2 (Go): affected from 2.1.0; fixed in 2.14.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55191/ (Markdown: https://insights.sbomify.com/CVE-2025-55191/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55191
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55191
- OSV: https://osv.dev/vulnerability/CVE-2025-55191

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55191/
Summaries are generated and may contain mistakes; the official description above is the record.
