# CVE-2025-55194: Part-DB Persistent Denial of Service via Uncaught Exception from Misleading File Extension in Avatar Upload

> Authenticated users can cause persistent denial of service by uploading profile pictures with misleading file extensions, blocking profile access.

- **Severity:** Medium 5.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 13 Aug 2025
- **Updated:** 14 Aug 2025
- **Also known as:** GHSA-7rv3-rcxv-69ww

## What is CVE-2025-55194?

CVE-2025-55194 is a medium-severity denial of service vulnerability in Part-DB-server, published on 13 Aug 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Part-DB is an open source inventory management system for electronic components. Prior to version 1.17.3, any authenticated user can upload a profile picture with a misleading file extension (e.g., .jpg.txt), resulting in a persistent 500 Internal Server Error when attempting to view or edit that user’s profile. This makes the profile permanently inaccessible via the UI for both users and administrators, constituting a Denial of Service (DoS) within the user management interface. This issue has been patched in version 1.17.3.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2025-55194?

It affects 1 product.


Products: Part-Db Project Part-Db.

## How do I fix CVE-2025-55194?

No fix has been published for CVE-2025-55194 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-55194 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55194 exists.

## Other vulnerabilities in Part-DB-server

- [CVE-2022-0848](https://insights.sbomify.com/CVE-2022-0848/): OS Command Injection in part-db/part-db (critical 10.0)
- [CVE-2023-26042](https://insights.sbomify.com/CVE-2023-26042/): HTML/XSS injection possibilities in Part-DB (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55194 and fix it if it is affected.

What it is: CVE-2025-55194 is a medium-severity denial of service vulnerability in Part-DB-server, published on 13 Aug 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55194 exists.

Affected product: Part-DB-server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55194/ (Markdown: https://insights.sbomify.com/CVE-2025-55194/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55194
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55194
- OSV: https://osv.dev/vulnerability/CVE-2025-55194

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55194/
Summaries are generated and may contain mistakes; the official description above is the record.
