# CVE-2025-55195: @std/toml Prototype Pollution in Node.js and Browser

> Attackers can pollute the prototype chain in Node.js and browsers via untrusted TOML data, potentially leading to code execution or privilege escalation.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Aug 2025
- **Updated:** 14 Aug 2025
- **Also known as:** GHSA-crjp-8r9q-2j9r

## What is CVE-2025-55195?

CVE-2025-55195 is a high-severity vulnerability in denoland std, published on 14 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@std/toml is the Deno Standard Library. Prior to version 1.0.9, an attacker can pollute the prototype chain in Node.js runtime and Browser when parsing untrusted TOML data, thus achieving Prototype Pollution (PP) vulnerability. This is because the library is merging an untrusted object with an empty object, which by default the empty object has the prototype chain. This issue has been patched in version 1.0.9.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2025-55195?


## How do I fix CVE-2025-55195?

No fix has been published for CVE-2025-55195 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-55195 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55195 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55195 and fix it if it is affected.

What it is: CVE-2025-55195 is a high-severity vulnerability in denoland std, published on 14 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55195 exists.

Affected product: denoland std. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55195/ (Markdown: https://insights.sbomify.com/CVE-2025-55195/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55195
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55195
- OSV: https://osv.dev/vulnerability/CVE-2025-55195

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55195/
Summaries are generated and may contain mistakes; the official description above is the record.
