CVE-2025-55196 External Secrets Operator's Missing Namespace Restriction Allows Unauthorized Secret Access

High 7.1 Published Updated

Attackers can bypass namespace restrictions to read secrets across the cluster by exploiting missing namespace selectors in list operations.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-55196?

CVE-2025-55196 is a high-severity missing authorization vulnerability in external-secrets, published on 13 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

External Secrets Operator is a Kubernetes operator that integrates external secret management systems. From version 0.15.0 to before 0.19.2, a vulnerability was discovered where the List() calls for Kubernetes Secret and SecretStore resources performed by the PushSecret controller did not apply a namespace selector. This flaw allowed an attacker to use label selectors to list and read secrets/secret-stores across the cluster, bypassing intended namespace restrictions. An attacker with the ability to create or update PushSecret resources and control SecretStore configurations could exploit this vulnerability to exfiltrate sensitive data from arbitrary namespaces. This could lead to full disclosure of Kubernetes secrets, including credentials, tokens, and other sensitive information stored in the cluster. This vulnerability has been patched in version 0.19.2. A workaround for this issue includes auditing and restricting RBAC permissions so that only trusted service accounts can create or update PushSecret and SecretStore resources.

Weakness: CWE-284

Which versions are affected by CVE-2025-55196?

3 open source packages ship an affected version, including github.com/external-secrets/external-secrets.

PackageAffectedFixed in
github.com/external-secrets/external-secrets GoFrom 0.15.00.19.2
github.com/external-secrets/external-secrets GoFrom 0.15.00.19.2
github.com/external-secrets/external-secrets GoFrom 0.15.00.19.2

How do I fix CVE-2025-55196?

Upgrade github.com/external-secrets/external-secrets to 0.19.2 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-55196 being exploited?

There is no known exploitation of CVE-2025-55196 in the wild and no public exploit code.

Sources

Also known as GHSA-fcxq-v2r3-cc8h, GO-2025-3885, MINI-q28f-6gqv-jjrj.

Is CVE-2025-55196 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free