# CVE-2025-55197: pypdf's Manipulated FlateDecode streams can exhaust RAM

> Attackers can exhaust RAM by crafting malicious PDFs with specific FlateDecode filters, causing denial of service in applications using pypdf.

- **Severity:** Medium 6.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2025
- **Updated:** 14 Aug 2025
- **Also known as:** CLSA-2025-1759968741, DEBIAN-CVE-2025-55197, GHSA-7hfw-26vp-jp8m, PYSEC-2026-1830, UBUNTU-CVE-2025-55197, openSUSE-SU-2025:15439-1

## What is CVE-2025-55197?

CVE-2025-55197 is a medium-severity denial of service vulnerability in Pypdf Project Pypdf, published on 13 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

pypdf is a free and open-source pure-python PDF library. Prior to version 6.0.0, an attacker can craft a PDF which leads to the RAM being exhausted. This requires just reading the file if a series of FlateDecode filters is used on a malicious cross-reference stream. Other content streams are affected on explicit access. This issue has been fixed in 6.0.0. If an update is not possible, a workaround involves including the fixed code from pypdf.filters.decompress into the existing filters file.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-55197?

3 open source packages ship an affected version, including pypdf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pypdf` | PyPI | All versions | 6.0.0 |
| `pypdf` | PyPI | All versions | 6.0.0 |
| `pypdf` | PyPI | All versions | 6.0.0 |
| `python-pypdf` | openSUSE:Tumbleweed | All versions | 6.0.0-1.1 |

Products: Pypdf Project Pypdf.

## How do I fix CVE-2025-55197?

Upgrade pypdf to 6.0.0 or later.

## Is CVE-2025-55197 being exploited?

There is no known exploitation of CVE-2025-55197 in the wild and no public exploit code.

## Other vulnerabilities in Pypdf Project Pypdf

- [CVE-2026-102993](https://insights.sbomify.com/CVE-2026-102993/): pypdf: Possible large memory usage when retrieving Roman page labels (high 8.7)
- [CVE-2026-102994](https://insights.sbomify.com/CVE-2026-102994/): pypdf: Possible long runtimes/large memory usage when parsing indirect objects (high 8.7)
- [CVE-2026-102995](https://insights.sbomify.com/CVE-2026-102995/): pypdf: Possible large memory usage for large /ToUnicode streams (Follow-up 2) (high 8.7)
- [CVE-2026-102996](https://insights.sbomify.com/CVE-2026-102996/): pypdf: Possible large memory usage when parsing font data (high 8.7)
- [CVE-2026-102997](https://insights.sbomify.com/CVE-2026-102997/): pypdf: Possible long runtimes for partially malformed FlateDecode streams (Follow-up) (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55197 and fix it if it is affected.

What it is: CVE-2025-55197 is a medium-severity denial of service vulnerability in Pypdf Project Pypdf, published on 13 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-55197 in the wild and no public exploit code.

Affected packages and fixed versions:
- pypdf (PyPI): affected all versions; fixed in 6.0.0
- pypdf (PyPI): affected all versions; fixed in 6.0.0
- pypdf (PyPI): affected all versions; fixed in 6.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55197/ (Markdown: https://insights.sbomify.com/CVE-2025-55197/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55197
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55197
- OSV: https://osv.dev/vulnerability/CVE-2025-55197

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55197/
Summaries are generated and may contain mistakes; the official description above is the record.
