# CVE-2025-55198: Helm May Panic Due To Incorrect YAML Content

> Attackers can cause Helm to panic and crash by providing malformed YAML files, disrupting Kubernetes chart management operations.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Aug 2025
- **Updated:** 14 Aug 2025
- **Also known as:** AZL-66315, BIT-helm-2025-55198, CLEANSTART-2026-CD99087, CLEANSTART-2026-JC23745, CLEANSTART-2026-ON36329, ECHO-dae0-c4a3-662c, GHSA-f9f8-9pmf-xv68, GO-2025-3888, MINI-2whr-j866-5c6v, MINI-3pcf-9q83-hv7g, MINI-44wx-j6v6-8gq8, MINI-4r6v-8c5q-hq9c, MINI-779c-f52j-vj2h, MINI-7x54-q3j2-w4pv, MINI-8432-fqwv-2gf8, MINI-8jh5-m4fr-cxjc, MINI-8v54-p2cx-3589, MINI-8vhv-xcgv-g2f8, MINI-9jpj-3qpg-p6f2, MINI-c94p-32rx-jg85, MINI-cvrh-7gvp-w2r9, MINI-f4g9-6g6f-xxcf, MINI-fx7c-78jv-v4pg, MINI-grhm-w2c9-f237, MINI-h8ph-x855-73hf, MINI-hrmm-9h8h-jp4c, MINI-jmf7-fjp6-53r8, MINI-jw4g-8pj5-hwhj, MINI-mqhf-x823-qrh5, MINI-r346-85mw-r9h3, MINI-v3r5-6h32-5q4v, MINI-w7pj-q69f-7fjq, MINI-x6p6-rh2x-j9x8, MINI-xrhc-mw27-9v9p

## What is CVE-2025-55198?

CVE-2025-55198 is a medium-severity denial of service vulnerability in helm, published on 13 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Helm is a package manager for Charts for Kubernetes. Prior to version 3.18.5, when parsing Chart.yaml and index.yaml files, an improper validation of type error can lead to a panic. This issue has been resolved in Helm 3.18.5. A workaround involves ensuring YAML files are formatted as Helm expects prior to processing them with Helm.

Weakness: CWE-908 (Use of Uninitialized Resource)

## Which versions are affected by CVE-2025-55198?

5 open source packages ship an affected version, including helm.sh/helm/v3, helm and helm.sh/helm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `helm.sh/helm/v3` | Go | All versions | 3.18.5 |
| `helm.sh/helm/v3` | Go | All versions | 3.18.5 |
| `helm.sh/helm/v3` | Go | All versions | 3.18.5 |
| `helm` | Bitnami | All versions | 3.18.5 |
| `helm.sh/helm` | Go | All versions | None |

Products: Helm Helm.

## How do I fix CVE-2025-55198?

Upgrade helm.sh/helm/v3 to 3.18.5 or later.

## Is CVE-2025-55198 being exploited?

There is no known exploitation of CVE-2025-55198 in the wild and no public exploit code.

## Other vulnerabilities in helm

- [CVE-2019-18658](https://insights.sbomify.com/CVE-2019-18658/): Helm Unsafe Link Following (critical 9.8)
- [CVE-2019-1010275](https://insights.sbomify.com/CVE-2019-1010275/): Helm Improper Certificate Validation (critical 9.8)
- [CVE-2019-25210](https://insights.sbomify.com/CVE-2019-25210/): Information disclosure in n/a (critical 9.1)
- [CVE-2025-53547](https://insights.sbomify.com/CVE-2025-53547/): Helm Chart Dependency Updating With Malicious Chart.yaml Content And Symlink Can Lead To Code Execution (high 8.5)
- [CVE-2020-11013](https://insights.sbomify.com/CVE-2020-11013/): lookup Function Information Discolosure in Helm (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55198 and fix it if it is affected.

What it is: CVE-2025-55198 is a medium-severity denial of service vulnerability in helm, published on 13 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-55198 in the wild and no public exploit code.

Affected packages and fixed versions:
- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.18.5
- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.18.5
- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.18.5
- helm (Bitnami): affected all versions; fixed in 3.18.5
- helm.sh/helm (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55198/ (Markdown: https://insights.sbomify.com/CVE-2025-55198/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55198
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55198
- OSV: https://osv.dev/vulnerability/CVE-2025-55198

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55198/
Summaries are generated and may contain mistakes; the official description above is the record.
