# CVE-2025-55201: Copier safe template has arbitrary filesystem read/write access

> Attackers can read and write arbitrary files via exposed pathlib objects in Jinja context, bypassing filesystem security controls.

- **Severity:** High 8.5 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Aug 2025
- **Updated:** 18 Aug 2025
- **Also known as:** GHSA-3xw7-v6cj-5q8h, PYSEC-2026-1271

## What is CVE-2025-55201?

CVE-2025-55201 is a high-severity path traversal vulnerability in copier-org copier, published on 18 Aug 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Copier library and CLI app for rendering project templates. Prior to 9.9.1, a safe template can currently read and write arbitrary files because Copier exposes a few pathlib.Path objects in the Jinja context which have unconstrained I/O methods. This effectively renders the security model w.r.t. filesystem access useless. This vulnerability is fixed in 9.9.1.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-55201?

3 open source packages ship an affected version, including copier.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `copier` | PyPI | All versions | 9.9.1 |
| `copier` | PyPI | All versions | 9.9.1 |
| `copier` | PyPI | All versions | 9.9.1 |

## How do I fix CVE-2025-55201?

Upgrade copier to 9.9.1 or later.

## Is CVE-2025-55201 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55201 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55201 and fix it if it is affected.

What it is: CVE-2025-55201 is a high-severity path traversal vulnerability in copier-org copier, published on 18 Aug 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-55201 exists.

Affected packages and fixed versions:
- copier (PyPI): affected all versions; fixed in 9.9.1
- copier (PyPI): affected all versions; fixed in 9.9.1
- copier (PyPI): affected all versions; fixed in 9.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55201/ (Markdown: https://insights.sbomify.com/CVE-2025-55201/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55201
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55201
- OSV: https://osv.dev/vulnerability/CVE-2025-55201

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55201/
Summaries are generated and may contain mistakes; the official description above is the record.
