# CVE-2025-55202: Opencast has a partial path traversal vulnerability in UI config

> Attackers can read files from adjacent directories due to insufficient path validation in the UI config module of Opencast.

- **Severity:** Low 2.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Aug 2025
- **Updated:** 29 Aug 2025
- **Also known as:** GHSA-hq8m-v68g-8cf8

## What is CVE-2025-55202?

CVE-2025-55202 is a low-severity path traversal vulnerability in opencast, published on 29 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Opencast is a free, open-source platform to support the management of educational audio and video content. In version 18.0 and versions before 17.7, the protections against path traversal attacks in the UI config module are insufficient, still partially allowing for attacks in very specific cases. The path is checked without checking for the file separator. This could allow attackers access to files within another folder which starts with the same path. This issue has been fixed in versions 17.7 and 18.1. To mitigate this issue, check for folders that start with the same path as the ui-config folder.

Weakness: CWE-23 (Relative Path Traversal)

## Which versions are affected by CVE-2025-55202?

4 open source packages ship an affected version, including org.opencastproject:opencast-user-interface-configuration. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opencastproject:opencast-user-interface-configuration` | Maven | All versions | 17.7 |
| `org.opencastproject:opencast-user-interface-configuration` | Maven | All versions | 17.7 |
| `org.opencastproject:opencast-user-interface-configuration` | Maven | From 18.0 | 18.1 |
| `org.opencastproject:opencast-user-interface-configuration` | Maven | From 18.0 | 18.1 |

Products: Apereo Opencast.

## How do I fix CVE-2025-55202?

Upgrade org.opencastproject:opencast-user-interface-configuration to a fixed version for your release line: 17.7 or 18.1.

## Is CVE-2025-55202 being exploited?

There is no known exploitation of CVE-2025-55202 in the wild and no public exploit code.

## Other vulnerabilities in opencast

- [CVE-2021-43821](https://insights.sbomify.com/CVE-2021-43821/): Files Accessible to External Parties in Opencast (critical 9.9)
- [CVE-2020-5206](https://insights.sbomify.com/CVE-2020-5206/): Authentication Bypass For Endpoints With Anonymous Access in OpenCast (high 8.7)
- [CVE-2021-32623](https://insights.sbomify.com/CVE-2021-32623/): Opencast vulnerable to billion laughs attack (XML bomb) (high 8.1)
- [CVE-2020-5229](https://insights.sbomify.com/CVE-2020-5229/): Opencast stores passwords using outdated MD5 hash algorithm (high 7.7)
- [CVE-2020-5230](https://insights.sbomify.com/CVE-2020-5230/): Opencast uses unsafe identifiers (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55202 and fix it if it is affected.

What it is: CVE-2025-55202 is a low-severity path traversal vulnerability in opencast, published on 29 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-55202 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.opencastproject:opencast-user-interface-configuration (Maven): affected all versions; fixed in 17.7
- org.opencastproject:opencast-user-interface-configuration (Maven): affected all versions; fixed in 17.7
- org.opencastproject:opencast-user-interface-configuration (Maven): affected from 18.0; fixed in 18.1
- org.opencastproject:opencast-user-interface-configuration (Maven): affected from 18.0; fixed in 18.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55202/ (Markdown: https://insights.sbomify.com/CVE-2025-55202/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55202
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55202
- OSV: https://osv.dev/vulnerability/CVE-2025-55202

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55202/
Summaries are generated and may contain mistakes; the official description above is the record.
