# CVE-2025-55203: Plane Stored XSS in Add Work Item Functionality

> Attackers can inject malicious scripts into work item descriptions, leading to session hijacking or data theft when other users view the content.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 15 Aug 2025
- **Updated:** 15 Aug 2025
- **Also known as:** GHSA-rwjc-xhh3-m9m9

## What is CVE-2025-55203?

CVE-2025-55203 is a medium-severity cross-site scripting vulnerability in makeplane plane, published on 15 Aug 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Plane is open-source project management software. Prior to version 0.28.0, a stored cross-site scripting (XSS) vulnerability exists in the description_html field of Plane. This flaw allows an attacker to inject malicious JavaScript code that is stored and later executed in other users’ browsers. The description_html field is not properly sanitized or escaped. An attacker can submit crafted JavaScript payloads that are saved in the application’s database. When another user views the affected content, the injected code executes in their browser, running in the application’s context and bypassing standard security protections. Successful exploitation can lead to session hijacking, theft of sensitive information, or forced redirection to malicious sites. The vulnerability can also be chained with CSRF attacks to perform unauthorized actions, or leveraged to distribute malware and exploit additional browser vulnerabilities. This issue has been patched in version 0.28.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-55203?


## How do I fix CVE-2025-55203?

No fix has been published for CVE-2025-55203 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-55203 being exploited?

There is no known exploitation of CVE-2025-55203 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55203 and fix it if it is affected.

What it is: CVE-2025-55203 is a medium-severity cross-site scripting vulnerability in makeplane plane, published on 15 Aug 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-55203 in the wild and no public exploit code.

Affected product: makeplane plane. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55203/ (Markdown: https://insights.sbomify.com/CVE-2025-55203/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55203
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55203
- OSV: https://osv.dev/vulnerability/CVE-2025-55203

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55203/
Summaries are generated and may contain mistakes; the official description above is the record.
