CVE-2025-55209 FreePBX UCP is Vulnerable to Stored XSS Through its User Control Panel
Low-privileged users can inject malicious scripts into FreePBX UCP, leading to admin session hijacking and privilege escalation.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2025-55209?
CVE-2025-55209 is a medium-severity cross-site scripting vulnerability in FreePBX contactmanager, published on 4 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
contactmanager is a module for FreePBX@, which is an open source GUI that controls and manages Asterisk© (PBX). In versions 15.0.14 and below, 16.0.0 through 16.0.26.4 and 17.0.0 through 17.0.5, a stored cross-site scripting (XSS) vulnerability in FreePBX allows a low-privileged User Control Panel (UCP) user to inject malicious JavaScript into the system. The malicious code executes in the context of an administrator when they interact with the affected component, leading to session hijacking and potential privilege escalation. This issue is fixed in versions 15.0.14, 16.0.27 and 17.0.6.
Weakness: CWE-79
Which versions are affected by CVE-2025-55209?
How do I fix CVE-2025-55209?
No fix has been published for CVE-2025-55209 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-55209 being exploited?
There is no known exploitation of CVE-2025-55209 in the wild and no public exploit code.
Sources
Also known as GHSA-j654-x3q2-6wm3.