{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-55209 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-55209 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-55209 is a medium-severity cross-site scripting vulnerability in FreePBX contactmanager, published on 4 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-55209 and fix it if it is affected.\n\nWhat it is: CVE-2025-55209 is a medium-severity cross-site scripting vulnerability in FreePBX contactmanager, published on 4 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-55209 in the wild and no public exploit code.\n\nAffected product: FreePBX contactmanager. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-55209/ (Markdown: https://insights.sbomify.com/CVE-2025-55209/index.md)","id":"CVE-2025-55209","markdown":"https://insights.sbomify.com/CVE-2025-55209/index.md","name":"CVE-2025-55209","record":{"aliases":["GHSA-j654-x3q2-6wm3"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"FreePBX UCP module","requires_auth":"low_privilege","summary":"Low-privileged users can inject malicious scripts into FreePBX UCP, leading to admin session hijacking and privilege escalation.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"contactmanager is a module for FreePBX@, which is an open source GUI that controls and manages Asterisk© (PBX). In versions 15.0.14 and below, 16.0.0 through 16.0.26.4 and  17.0.0 through 17.0.5, a stored cross-site scripting (XSS) vulnerability in FreePBX allows a low-privileged User Control Panel (UCP) user to inject malicious JavaScript into the system. The malicious code executes in the context of an administrator when they interact with the affected component, leading to session hijacking and potential privilege escalation. This issue is fixed in versions 15.0.14, 16.0.27 and 17.0.6.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"FreePBX UCP is Vulnerable to Stored XSS Through its User Control Panel","id":"CVE-2025-55209","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"FreePBX API has a Privilege Escalation Error in GraphQL Allowing Authenticated Users to Access Additional Scopes","id":"CVE-2025-55210"},"packages":[],"prev":{"headline":"Chamilo LMS has Stored Cross Site Scripting on Social Networks Uploaded Files","id":"CVE-2025-55208"},"products":["contactmanager"],"published":"2025-09-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-13","vendors":["FreePBX"]},"summary":"Low-privileged users can inject malicious scripts into FreePBX UCP, leading to admin session hijacking and privilege escalation.","url":"https://insights.sbomify.com/CVE-2025-55209/"}