# CVE-2025-55209: FreePBX UCP is Vulnerable to Stored XSS Through its User Control Panel

> Low-privileged users can inject malicious scripts into FreePBX UCP, leading to admin session hijacking and privilege escalation.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 4 Sep 2025
- **Updated:** 13 Feb 2026
- **Also known as:** GHSA-j654-x3q2-6wm3

## What is CVE-2025-55209?

CVE-2025-55209 is a medium-severity cross-site scripting vulnerability in FreePBX contactmanager, published on 4 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

contactmanager is a module for FreePBX@, which is an open source GUI that controls and manages Asterisk© (PBX). In versions 15.0.14 and below, 16.0.0 through 16.0.26.4 and  17.0.0 through 17.0.5, a stored cross-site scripting (XSS) vulnerability in FreePBX allows a low-privileged User Control Panel (UCP) user to inject malicious JavaScript into the system. The malicious code executes in the context of an administrator when they interact with the affected component, leading to session hijacking and potential privilege escalation. This issue is fixed in versions 15.0.14, 16.0.27 and 17.0.6.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-55209?


## How do I fix CVE-2025-55209?

No fix has been published for CVE-2025-55209 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-55209 being exploited?

There is no known exploitation of CVE-2025-55209 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-55209 and fix it if it is affected.

What it is: CVE-2025-55209 is a medium-severity cross-site scripting vulnerability in FreePBX contactmanager, published on 4 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-55209 in the wild and no public exploit code.

Affected product: FreePBX contactmanager. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-55209/ (Markdown: https://insights.sbomify.com/CVE-2025-55209/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-55209
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-55209
- OSV: https://osv.dev/vulnerability/CVE-2025-55209

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-55209/
Summaries are generated and may contain mistakes; the official description above is the record.
